1

I have a Wordpress dev site that we want to bring live with lots of new exciting content. The CiviCRM is out of date so I make a staging site and attempt to upgrade that to 5.33.1 from 5.32.2 so sadly the comment below, whilst very welcome and informative, does not take me any closer to a solution.

On entering the magic URL

http://example.org/wp-admin/admin.php?page=CiviCRM&q=civicrm/upgrade&reset=1

(with example.org corrected of course and using https:)
I get the utterly useless and unhelpful error msg

Sorry, you are not allowed to access this page.

I have full admin rights and am left wondering what went wrong and why. Meanwhile I am under pressure to deliver the shiny new content in a secure manner.

all my links are https - what other security issues are there?

Am I better off redoing the site in Drupal as the WordPress is obviously not the focus of the CiviCRM devs? Will I get less hassle every time I need to upgrade?

5
  • 1
    I would say that is not the case. WordPress is getting more love all the time. However as @Demerit notes, there was a URL change back at 5.26. Have you tried converting the URL to the newer syntax? page= was swapped to be civiwp= I think. – kapn Jan 15 at 20:57
  • THank you - I looked at this and using the new URL simply gave me a blank page and no error message. – Southside Jan 16 at 16:46
  • Would it be fair to say that the docs are not 100% up to date? – Southside Jan 16 at 16:47
  • 1
    I would say that is fair to say of any documentation. How much that is true here, I can't really say. I haven't had upgrade troubles that weren't solved by reverting to backup and trying again more carefully and reviewing logs as I go. Have you looked in the web server error logs and in the CiviCRM logs (uploads/civicrm/ConfigAndLog)? I have often found useful clues there when the on screen message is not so helpful. The security issues are most likely to be either local permissions on directories. Maybe owner set to root and www-data can't read? – kapn Jan 17 at 15:08
  • Thank you for the hint on the log location I see [warning] The system has data from both old+new conventions. Please use civicrm.settings.php to set civicrm.files explicitly. I'll try to sort that out and see if it works after I get rid of that warning – Southside Jan 17 at 23:52
1

It sounds like this is the url change that happened in 5.26. If you're upgrading from before 5.26 see https://civicrm.org/blog/kcristiano/civicrm-526-and-wordpress-important-notice

2
  • This is (trying to) upgrade from 5.32. – Southside Jan 15 at 21:45
  • 1
    I don't know offhand what else it could be. I agree with kapn - try civiwp instead of page in the url. – Demerit Jan 15 at 21:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.