1

I am using Mailgun for sending the email newsletters. I do not use the Mailgun API for sending, just the standard SMPT configuration. Now MailGun sends me the following, bit disturbing email:

 Mailgun will no longer support TLS 1.0/1.1 

I assume CiviCRM uses a more recent version, but where can I find this?

1

For SMTP Civi by default uses pear::mail, which uses Net_SMTP. The current version of Net_SMTP that civi has supports TLS 1.2. See https://github.com/pear/Net_SMTP/blob/18b5dbaa049bee5f6d02c9a4318db02472e2c922/Net/SMTP.php#L613

It also depends on the version of the openssl extension you have installed in your php. If you run php -i | grep -i openssl or look at the output of phpinfo, you most likely have newer than openssl 1.0.1 so should be good.

1
  • Thanks, our installation is OK. I looked for the SSL version on https://<server>/admin/reports/status/php . (We use drupal 7). – Kainuk - CiviCooP Jan 21 at 8:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.