3

We are trying to set up a webform to open a case and assign a case role (manager).

I configured two contacts - coordinator and client - and assigned them to the case in the webform. The client as client and creator and the coordinator to the managing role of the case. For the coordinator contatc I set a static field with a default contact value.

The open case part works fine, but assigning the coordinator as manager does not work. Instead, the first contact (client) is also assigned as manager.

I also tried opening a case without a manager being set. But in this case, the manager role is also assigned to the client contact.

Does anyone have an idea what the problem could be?

System

CiviCRM v5.28.2

Drupal v7.78

Webform CiviCRM Integration v7.x-5.4

enter image description here

enter image description here enter image description here enter image description here

8
  • 1
    In the webform did you set a relationship between the client and the manager? That's how this is implemented in Civi's case system.
    – Andy Clark
    Jan 31 at 14:26
  • I am running slightly different versions of Civi and Webform Integration from you but we do use the webform to case integration heavily. Would you be willing to provide some screenshots of your setup? I'm wondering about the "The client as client and creator and the coordinator to the managing role of the case." portion. In my setups, the client is set as the client but the case creator and case manager are one in the same. (There may be updated language since I am behind a little on my version of the webform integration but I'm still happy to help if I can.)
    – RayWright
    Feb 4 at 3:01
  • @AndyClark I added them to the roles "Case Client" and "Case Creator/Manager" in the case tab. Is that what you meant?
    – PatricB
    Feb 14 at 18:12
  • @RayWright I added a screenshot of my case tab in the webform - do you need more?
    – PatricB
    Feb 14 at 18:20
  • 1
    What I mean is that in a webform, for a contact you can display 'Number of Relationship fields'. So here you would set that to 1 in the second contact, which I assume is the manager (the first being the client), and in that exposed relationship field you would set the 'Relationship to Contact 1' to be 'Case Manager'.
    – Andy Clark
    Feb 14 at 19:05
2

Finally it is working!

Two where important:

  1. Disable "Enforce Permissions" for the contact field in the webform config, filled with a default value. "Enforce Permissions" field
  2. Look out for the field "Update Existing Case" on the CiviCRM tab. It was set to a case status value, so it would change an existing case. "Update Existing Case" field

Many thanks to @AndyClark and @RayWright!

1
  • Glad you got it sorted!
    – Andy Clark
    Feb 25 at 19:51
1

All the screenshots are super helpful. I think because you have set it to be a static contact but did not tell it which contact, you are seeing an issue. Can you place the ID number of the desired case manager in the Contact (Kontakt) field right below "Set default contact from: Specified Contact"?

To test that it's working, you might turn on Display Contact Name - just to check that then the form is dispalying the name of the contact you set.

4
  • I tried to place the ID of the contact into the field for the default value, but I can't save it. I can only search and select a contact from the search result. I also turned on "Display Contact Name". If open the webform as anonymouse user, the field for the case manager is empty ("- None Found -"). If open it as logged in user, it is filled with the seleceted contact. (I also disabled "Private" for debugging) I disabled then "Enforce Permissions" and now the default selected contact is set in the result, but sadly no more case is added...
    – PatricB
    Feb 24 at 17:36
  • @PatricB I feel like we can get this going but it might be easier to ask several questions at once. If you want to find me in chat - perhaps that will be quicker?
    – RayWright
    Feb 24 at 22:43
  • sry, for now my reputation is to low...
    – PatricB
    Feb 25 at 18:07
  • Do you have changed any permissions in drupal to let this work?
    – PatricB
    Feb 25 at 18:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.