2

Has anyone tried running civibuild recently to create a CiviCRM environment under Drupal 9? I have been running it on a Ubuntu 20.4 virtual machine and hit various issues. To build drupal9-clean I had to copy composer from a running Drupal 9 instance to buildkit/build/drupal9-clean/vendor as it was not installed by civibuild.

2
  • 1
    About 2 months ago I did it for something and it seemed ok. The d9-master.demo.civicrm.org site is built daily using it. I remember there being some issues with composer v2 - not sure if that's been settled. Which version of composer do you have?
    – Demerit
    Feb 16 '21 at 13:09
  • Thanks - it wasn't composer that was broken, but the composer directory tree. I've just built drupal9-demo, but it needed two passes. Civibuild just seems a bit fragile. Feb 17 '21 at 16:19
0

Edit: As of 8-26-2021 the below command works just fine with current buildkit, it's just not in the civibuild docs yet afaik:

civibuild create d9dev --type drupal9-clean --civi-ver master --url http://d9.localhost

As of today (4-21-2021 env Ubuntu 20.04), I used the command

civibuild create d9dev --type drupal9-clean --civi-ver master --url http://d9.localhost

Which ran into errors because it couldn't find a valid civicrm root (/vendor did not include a civicrm directory at this time). I needed to run the command, then manually:

composer config extra.enable-patching true
composer config minimum-stability dev
composer require civicrm/civicrm-asset-plugin:'~1.1'
composer require civicrm/civicrm-{core,packages,drupal-8}:'~5.35'

Then I ran the same civibuild command again to finish out the build process and get the .sh file with login info etc. I ended up with a working copy of Drupal 9 version 9.0.12-dev and CiviCRM 5.36.0.

Hope that's helpful!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.