4

I am not a PHP/SQL programmer. Our CivicCRM is Version 4.7. PHP is 7.3.27. I upgraded our WordPress site to WP 5.6.1 and now get these errors:

Warning: count(): Parameter must be an array or an object that implements Countable
in /home/rembrand/public_html/wordpress/wp-content/plugins/civicrm/civicrm/packages/DB.php
on line 793

Warning: Cannot modify header information - headers already sent by (output started
at /home/rembrand/public_html/wordpress/wp-content/plugins/civicrm/civicrm/packages/DB.php:793)
in /home/rembrand/public_html/wordpress/wp-admin/admin-header.php
on line 9

if (!count($dsn)) {
            return $parsed;
        }

Warning appears at top of screen when I enter Wordpress admin dashboard for our website and edit any page.

How do I fix this?

2
  • You appear to be trying to edit this question as a different user so your edits are pending review. Best if you can log in as the same user to make edits to your question. – William Mortada Mar 26 at 12:21
  • I see in your edits that you're running CiviCRM 4.7. This is many years out of date. You'll need to upgrade CiviCRM to a version that supports your current version of PHP. – Jon G - Megaphone Tech Mar 26 at 13:29
2

It sounds like you're running PHP 7.2 or greater with a version of CiviCRM that doesn't support PHP 7.2+. If you edit your question to include your CiviCRM version, that could help folks troubleshoot. However, it sounds like you may need to upgrade your CiviCRM to a version that supports 7.2.

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.