0

Experiencing a strange situation where the database upgrade url worked perfectly for a testing site but not for the live site.

I successfully tested the upgrade with a cloned staging site without a hitch in the upgrade process.

https://staging.islandnaturetrust.ca/

By following the CiviCRM Wordpress upgrade guide: https://docs.civicrm.org/sysadmin/en/latest/upgrade/wordpress/

However, as soon as I attempted on the main site the updgrade database url loops back to the WP login page.

https://www.islandnaturetrust.ca/

Steps:

  1. Login as administrator for wordpress site
  2. Paste upgrade database url into browser http://islandnaturetrust.ca/wp-admin/admin.php?page=CiviCRM&q=civicrm/upgrade&reset=1
  3. Page redirects to WP login page with no errors.
  4. Login once more
  5. Paste URL
  6. Returned back to WP login page

I've checked the CiviCRM debug log but no errors reported.

Thoughts anyone?

UPDATE: Upgrading from 5.25 to 5.34

2
  • Would be useful to know what version of CiviCRM you are upgrading from and to.
    – Mick Kahn
    Feb 27 at 17:05
  • 1
    My bad. 5.25 to 5.34 Mar 1 at 19:01
1

I stumbled across a work around purely by accident but to cut a long story short:

Problem is that since the upgrade database url points to an unsecure http file, my server then wants to redirect to the secure url - resetting the session - requiring an admin login (not sure why this is since automatic SSL redirects have been disabled). Using the upgrade url, I deliberately added an additional character/integer to the url end, forcing the browser to navigate to a http page that doesn't exist. Now that I was sitting in a unsecure 404 page, I simply deleted the previously added character/integer and voila; no redirect to a secure page and consequently the upgrade screen correctly loads.

2
  • Glad you made it work. As you found a http/https mix causes problems. Also 'www.' and no www causes problems. Decide what you want to use and make sure civicrm.settings.php is consistent.
    – Aidan
    Mar 1 at 15:32
  • Ah, consistency in civicrm.settings.php. I'll review and amend. Thanks Aidan Mar 1 at 19:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.