0

I sent out a mass mailing via CiviMail and the reply-to email is default+r{seemingingly_random_string}@gmail.com I am using Sparkpost to send these mailings. CiviCRM 5.29.1 Any idea why the reply-to email is this odd-looking email and not the same as the From address?

1

This is a mechanism for handling bounce messages and replies in response to the mailing so that they are associated with the individual that mail was sent to. It is quite complicated and you should start by reading https://docs.civicrm.org/sysadmin/en/latest/setup/civimail/ and probably also the Sparkpost documentation as well. Too much to explain here. I presume that you didn't set the Sparkpost up. You could talk to whoever did.

1

Is reply-to tracking enabled? It might be adding VERP tracking, as Mick mentions.

Otherwise, I recently noticed that CiviMail will use the default site "From" as the Reply-To, unless the Reply-To override option was enabled in the CiviMail Settings. (this seemed a bit counter-intuitive to me, I would have assumed that the Reply-To would default to the same address as the From)

1
  • 1
    Thanks. I was able to solve this issue by going CiviMail > CiviMail Component Settings. I unchecked the box "Track replies using VERP in Reply-To header" and the reply-to looks normal now. – menachem Mar 3 at 21:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.