1

I'm using the current instructions to get the current version of CiviCRM for Drupal 8

[play@ceres web]$ composer require civicrm/civicrm-{core,packages,drupal-8}:'~5.35'

It keeps giving me this error

- The requested package civicrm/civicrm-core ~5.35 is satisfiable by civicrm/civicrm-core[5.35.x-dev] but these conflict with your requirements or minimum-stability.

I'm then trying

composer require civicrm/civicrm-{core,packages,drupal-8}:'~5.34.0’

and it just hangs.

Any ideas?

1
  • Im now getting the message 'killed' and it's running through 1gb memory, which can't be right..... – Tony Horrocks Mar 3 at 10:56
0

The memory problem is real - composer does that. You always need to export COMPOSER_MEMORY_LIMIT=-1.

For the conflict, is this drupal 9.1? You can try adding "minimum-stability": "dev" to composer.json.

3
  • 1
    OK I added the -W parameter to the composer thus composer -W require civicrm/civicrm-{core,packages,drupal-8}:'~5.34.0’ then it worked – Tony Horrocks Mar 3 at 19:05
  • Cool. There always seems to be some trial and error with composer and it's different in each environment. – Demerit Mar 3 at 19:10
  • Also I noticed I had an incorrect comma at the end which was breaking everything. Sigh. – Tony Horrocks Mar 3 at 20:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.