1

After running into problems setting up Views integration with CiviCRM installed on a separate database, I gave up and started my project over with CiviCRM installed on the same database as Drupal 9. This has solved the privileges problem I was having.

Here's my old question about the Privileges problem (which I'd still love an answer to if anyone has one!)

However, I'm now running into an issue where CiviCRM fields aren't showing up as an option in Views. The documentation seems to suggest that if CiviCRM is installed on the same db as Drupal, this data should show up with no further configuration needed.

If your CiviCRM and Drupal are located within the same database the 12 steps below are not required.

Help! What am I doing wrong?

EDIT: At @KarinG's suggestion I installed and enabled the CiviCRM Entity module, which has fixed the problem where CiviCRM entities weren't showing up as options in Views. However, I now have a problem where those entities are not showing up in the results. I've flushed Drupal's caches many times at this point.

EDIT: Here's a Screenshot of the View

No results are returned.

Thank you in advance for all your help! It really feels like there's just some silly box I've left unchecked somewhere.

2
  • Have you enabled any entities under /admin/structure/civicrm-entity/settings ? – Demerit Mar 6 at 12:57
  • Limit 11 -> remove that; – KarinG - Semper IT Mar 9 at 13:38
1

👋 Austin -> did you install and enable CiviCRM Entity Module?

6
  • Actually - I originall completely misread your Q! I thought you had separate databases - I now think you may be missing a module☝️ – KarinG - Semper IT Mar 7 at 16:58
  • Thank you, Karin! I hadn't set up CiviCRM Entity on this install because it was included in the "12 steps below" that the documentation said were "not required." I should have tried that! I am now able to get access to the entities in Views. However, I created 2 test Contacts and tried to pull their Display Names into a View and I get no results. I've enabled the Contact entity in /civicrm-entity/settings as @Demerit suggested. The View is set up to "Show: Fields" with "Field: CiviCRM Contact (CiviCRM Entity): Display Name" selected. Is there another obvious thing I'm missing? – Austin Zumbro Mar 7 at 20:41
  • I guess I should also say that /civicrm/admin/setting/uf?reset=1 doesn't show anything. When I was setting everything up on separate databases, that step worked fine. In the current context, I only see "CMS Users Table Name" and "Sync CMS Email" option and that's it. – Austin Zumbro Mar 7 at 23:34
  • i) You can scratch that CMS Integration step if you have one database; ii) You don’t have to enable the Contact Entity (to get the CiviCRM data into a View) but you do need to clear Drupal caches 2x (at least 🙂) after enabling CiviCRM entity – KarinG - Semper IT Mar 8 at 0:31
  • Thank you for all your help so far, Karin. I've flushed all the Drupal caches 10+ times now, and I'm still not getting any results in the View. Anything else I can try? – Austin Zumbro Mar 8 at 21:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.