1

I am trying to install CIVICRM on Drupal 9 as per instruction found here https://docs.civicrm.org/installation/en/latest/drupal9/

When i enter "composer require civicrm/civicrm-{core,packages,drupal-8}:'~5.29'" getting error as below .. how to resolve this issue ?

[root@srv public_html]# composer require civicrm/civicrm-{core,packages,drupal-8}:'~5.29' Do not run Composer as root/super user! See https://getcomposer.org/root for details Continue as root/super user [yes]? yes ./composer.json has been updated Running composer update civicrm/civicrm-core civicrm/civicrm-packages civicrm/civicrm-drupal-8 Loading composer repositories with package information Updating dependencies Your requirements could not be resolved to an installable set of packages.

Problem 1 - civicrm/civicrm-core[5.29.0, ..., 5.35.0] require pear/validate_finance_creditcard dev-master -> found pear/validate_finance_creditcard[dev-master] but it does not match your minimum-stability. - Root composer.json requires civicrm/civicrm-core ~5.29 -> satisfiable by civicrm/civicrm-core[5.29.0, ..., 5.35.0].

Installation failed, reverting ./composer.json and ./composer.lock to their original content.

Thanks Jaiz

2

You should replace 5.29 in the instructions with the current version. Right now it's 5.35.

And I thought the docs were updated for this but for drupal 9 you also need to add "minimum-stability": "dev" into composer.json.

Also don't run composer as the root user.

4
  • I have done what you suggested and got error Installation failed, reverting ./composer.json and ./composer.lock to their original content. [ErrorException] file_put_contents(/home/fimember/public_html/vendor/composer/installed.php): failed to open stream: Permission denied Jaisal – Jaizal Mar 13 at 4:37
  • If you ran it as root before then that folder is now owned by root, so you'll need to change the owner on everything in the vendor folder. Or just delete it if you're starting from scratch. – Demerit Mar 13 at 4:41
  • that solution worked! – Jaizal Mar 13 at 4:52
  • Great! Enjoy your civi site! – Demerit Mar 13 at 4:53
0

This issue we blogged about on Bug in CiviCRM Installer for Drupal 9 and the basic solution is to run this:

composer require pear/validate_finance_creditcard:dev-master

before you try to install. Then it works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.