0

I just tried to edit the source field on a membership that was entered a few months ago, and I just get the spinning CiviCRM logo of uncertainty. I've also noticed the same thing happens when I try to edit a date field or any other info on the membership form. Is this by design?

Additional info by request:

  • Drupal 7.38 and CiviCRM 4.6.4 Host is LiquidWeb and we've been running multiple CiviCRM sites on a VPS for them for years.

Console shows the following errors:

This site makes use of a SHA-1 Certificate; it's recommended you use certificates with signature algorithms that use hash functions stronger than SHA-1.[Learn More] __utm.gif &nbsp "The "fb-root" div has not been created, auto-creating"

I've turned on debugging and backtrace. I don't get anything for backtrace results when trying to edit the source field for the membership record - it's still spinning after ten minutes. I did get the following when I tried to merge two contacts, which is a separate question I posted here a week or so ago:

backTrace

  • 0 /home/repl00/public_html/sites/all/modules/civicrm/CRM/Core/Error.php(359): CRM_Core_Error::backtrace()
  • 1 /home/repl00/public_html/sites/all/modules/civicrm/CRM/Utils/Request.php(95): CRM_Core_Error::fatal("Could not find valid value for cid")
  • 2 /home/repl00/public_html/sites/all/modules/civicrm/CRM/Contact/Form/Merge.php(66): CRM_Utils_Request::retrieve("cid", "Positive", Object(CRM_Contact_Form_Merge), TRUE)
  • 3 /home/repl00/public_html/sites/all/modules/civicrm/CRM/Core/Form.php(455): CRM_Contact_Form_Merge->preProcess()
  • 4 /home/repl00/public_html/sites/all/modules/civicrm/CRM/Core/QuickForm/Action/Display.php(94): CRM_Core_Form->buildForm()
  • 5 /home/repl00/public_html/sites/all/modules/civicrm/packages/HTML/QuickForm/Controller.php(203): CRM_Core_QuickForm_Action_Display->perform(Object(CRM_Contact_Form_Merge), "display")
  • 6 /home/repl00/public_html/sites/all/modules/civicrm/packages/HTML/QuickForm/Page.php(103): HTML_QuickForm_Controller->handle(Object(CRM_Contact_Form_Merge), "display")
  • 7 /home/repl00/public_html/sites/all/modules/civicrm/CRM/Core/Controller.php(353): HTML_QuickForm_Page->handle("display")
  • 8 /home/repl00/public_html/sites/all/modules/civicrm/CRM/Utils/Wrapper.php(115): CRM_Core_Controller->run()
  • 9 /home/repl00/public_html/sites/all/modules/civicrm/CRM/Core/Invoke.php(286): CRM_Utils_Wrapper->run("CRM_Contact_Form_Merge", "Merge Contact", NULL)
  • 10 /home/repl00/public_html/sites/all/modules/civicrm/CRM/Core/Invoke.php(86): CRM_Core_Invoke::runItem((Array:13))
  • 11 /home/repl00/public_html/sites/all/modules/civicrm/CRM/Core/Invoke.php(54): CRM_Core_Invoke::_invoke((Array:3))
  • 12 /home/repl00/public_html/sites/all/modules/civicrm/drupal/civicrm.module(489): CRM_Core_Invoke::invoke((Array:3))
  • 13 internal function: civicrm_invoke("contact", "merge")
  • 14 /home/repl00/public_html/includes/menu.inc(519): call_user_func_array("civicrm_invoke", (Array:2))
  • 15 /home/repl00/public_html/index.php(21): menu_execute_active_handler()
  • 16 {main}
    • We'd like to help but we need more information. Please edit your answer to provide answers to : What CMS and Version CiviCRM version? Is it just one particular membership or does it happen for all membership entered 3 months ago? What about a membership you enter today, can you edit that? Did you upgrade either CiviCRM or you CMS in those 3 months? Did your host upgade anything? Were you once able to edit memberships but can no more or is this the first time you have tried to do so? Also anything else you can think of that might be relevant. – JoAnne Jul 13 '15 at 23:38
    • 1
      Also you can check console for any errors. As the logo goes on spinning might be due to some js break. Can also try the steps mentioned in forum.civicrm.org/index.php/topic,35850 which can help you to nail the issue – jitendra - fuzion Jul 14 '15 at 7:13
    • Anything appearing in your log files? Does the change work if you use the API explorer? – DaveFF Jul 14 '15 at 9:02
    • In your forum post, forum.civicrm.org/index.php/topic,36627, you state that "The primary issue is that we are unable to edit anything that pops up a separate window.". Have you tried disabling pop up windows as outlined in a reply on that topic and if so, did that let you edit membership records? – JoAnne Jul 15 '15 at 13:43

    Your Answer

    By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

    Browse other questions tagged or ask your own question.