0

Oracle VM

Linux Mint 20.1 Ulyssa

LAMP through Mint

Backdrop v1.18.1

CiviCRM 5.35.1 for Backdrop

I go to http://localhost and get Backdrop just fine.

I go to http://localhost/modules/civicrm/install/index.php and get "Oops! Incorrect CiviCRM version ... can only be used for Drupal version of CiviCRM".

I downloaded CiviCRM 5.35.1 for Backdrop three times, extracted, placed folder into modules and get that same message.

Clearly it is installed correctly or I wouldn't be getting that message. Perhaps the Backdropcms version and the CiviCRM version are not compatible?

/module/civicrm/README.md says it is good for Drupal, Wordpress and Joomla. but /module/civicrm/install/index.php line 67 says acceptable are "drupal, wordpress, backdrop"

Any help would be appreciated. Thanks in advance.

John in Medford, Oregon

3
  • 1
    Hi John -- have you tried this one? civicrm.stackexchange.com/a/11716/26 Mar 19 at 22:44
  • 2
    Key point: http://localhost/modules/civicrm/install/index.php?civicrm_install_type=backdrop Mar 19 at 22:51
  • I wound up editing var/www/html/modules/civicrm/install/index.php Line 76, which sets the install Else type $installtype = 'backdrop'; Thanks Laryn for the help.
    – OregonJohn
    Mar 20 at 8:00
2

Giving credit to Laryn, but not sure how to do that other than this.

Key point: http://localhost/modules/civicrm/install/index.php?civicrm_install_type=backdrop – Laryn - CEDC.org 22 hours ago

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.