0

HostGator has frozen their shared platforms at MySQL 5.6 with no plans to offer MySQL 5.7 to the shared packages, even though 5.6 went EOL on February 5th, 2021. They're pushing people to use their Virtual Private Server which is about 10x the cost of shared. So, if you're installing CiviCRM, DON'T host with HostGator. We'd like to stay up-to-date on CiviCRM, at least the security fixes, but the only option seems to be to pay for Extended Security Release. Are there any alternatives for those who have been locked out by their hosting platforms? cheers ... :) gn

4
  • care to give indication of the actual monthly costs for existing and VPS? – petednz - fuzion Mar 25 at 22:09
  • 1
    I was told the same thing by Siteground UK - it's hard to understand why they would not upgrade MySQL on the shared servers. However since Siteground's migration from cPanel to 'Site Tools' also became a problem I migrated my clients to hostinguk.net, solving both problems. – Andy Clark Mar 26 at 9:00
  • @petednz-fuzion - HostGator's shared platforms range from $2.75/mo (single-site) to $5.25/mo (unlimited sites + static IP). Virtual Private Server is $29.95/mo which, after adding in some of the site add-ons, is getting back to the $90/mo we were paying for hosted CRM :-\ – Geof Newton Mar 26 at 14:32
  • My experience with SiteGround UK has been different to Andy Clark . Yes, they were not prepared to offer MySQL 5.7 on cPanel for shared platforms, but they are migrating all customers away from that to Site Tools. I was worried about the move, thinking I'd loose quite a bit of functionality and have to deal with my test and training sites quite differently. When the move was forced it all went very smoothly and I had MySQL 5.7, I can do everything I need to and some functionality has improved, so I am happy – Mick Kahn Mar 27 at 0:19
3

Geoff - although I do want to encourage you to upgrade your mysql you are still able to install the free version of CiviCRM on mysql 5.6 at this stage. We are discussing when to stop supporting it over here https://lab.civicrm.org/dev/core/-/issues/2481

3
  • So to clarify, 5.35 is still supporting MySQL 5.6? The official doc says it needs 5.7+ but I hadn't seen any big notifications or warnings on the 5.34+ releases like I was expecting ~ – Geof Newton Mar 30 at 14:04
  • Yes - we did propose dropping 5.6 support but in the end didn't. – eileen Mar 31 at 4:54
  • Upgraded to 5.35.1 and all is right with the world :-). The big warning banner about the MySQL version on the db upgrade page is a little unsettling but the upgrade script completed without any issues. – Geof Newton Apr 1 at 21:18
1

I just wanted to add this in here...I think in terms of safety, it would probably be better to upgrade to the VPS or your own dedicated server. While expensive, I'm not sure I'd be OK with having constituent data on a shared hosting environment. It would also give you a bit more flexibility in terms of upgrades.

1
  • For many non-profits who rely solely on donor gifts to operate, I agree. For small, member-run non-profits / clubs, the shared environments from reputable providers segregate data sufficiently to meet most CRM and privacy needs. Flexibility would be nice though :-) – Geof Newton Mar 31 at 15:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.