1

After upgrading to 5.35.1 I am getting a memory limit reached error when loading the SMTP settings page. I am not sure if this is related but I am getting a growl error for "Failed to find key by ID or tag" and then a random string.

I have tried getting to the page with and without the CiviCRM Secret Keys set in my settings file. I have cleared the cache. My memory limit is set at an obscene 3000M.

I have this working on my dev server with the same SMTP settings. The dev server has the CiviCRM Secret Keys set. I am using;

define('CIVICRM_CRED_KEYS', '::SOME VALUE');

Any help or ideas of how to fix this are appreciated.

Thanks, Josh

2
  • Can you confirm the version, 5.31.1 is pretty old and has security vulnerabilities that are fixed in 5.35.1 :-) – HomoTechsual Mar 31 at 8:52
  • 1
    Thank you it is 5.35.1. Yikes, sorry! – Josh Mar 31 at 16:25
1

What I think happened is that added the encryption key after I did the upgrade. I am not sure how I did this. This was then causing the SMTP key not to be able to be read.

I got the idea that maybe I could force blank values into the STMP form. While there I found this code.

if (!empty($this->_defaults['smtpPassword'])) {
          $this->_defaults['smtpPassword'] = \Civi::service('crypto.token')->decrypt($this->_defaults['smtpPassword']$
        }

I commented this out and the form loaded. I saved without the key in the civicrm.settings.php file and then with the key again.

Now everything works correctly again.

1
  • This worked for me, thank you. I was getting an error "failed to find key by id or tag civicrm" – Jeffery Green Jun 11 at 0:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.