1

Salut. We recently upgraded to Civicrm 5.35.1 (Wordpress). When we try to send Emails to more than one recipient in Contacts->New Email, the operation fails (see screenshot attached). One recipient works fine. When I use one recipient and add the rest via CC or BCC, it works as well, but in this case tokens are ignored, won't work. Before the upgrade (5.25), we just added all Names in the top field and never used CC or BCC. Does anybody have similar experiences? I also attached the last lines in the logfile in ConfigandLog

error message

 Apr 05 11:32:27  [warning] Deprecated Path: There is a setting (generate_schema_and_data) not correctly defined. You may see unpredictability due to this. CRM_Core_Setting::setItems
Array
(
    [civi.tag] => deprecated
)


Apr 05 11:48:09  [info] Report Error Extension could not send since no email address was set.

Apr 05 11:48:09  [error] 
$Fatal Error Details = array:3 [
  "message" => "In ihrer Anfrage ist leider ein Fehler aufgetreten."
  "code" => null
  "exception" => CRM_Core_Exception {#25149
    -errorData: array:1 [
      "error_code" => 0
    ]
    #cause: null
    -_trace: null
    #message: "In ihrer Anfrage ist leider ein Fehler aufgetreten."
    #code: 0
    #file: "/home/gemeingut/www/www/wp-content/plugins/civicrm/civicrm/CRM/Mailing/Form/Optout.php"
    #line: 37
    trace: {
      /home/gemeingut/www/www/wp-content/plugins/civicrm/civicrm/CRM/Mailing/Form/Optout.php:37 {
        › if (!$q) {
        ›   throw new CRM_Core_Exception(ts("There was an error in your request"));
        › }
      }
      /home/gemeingut/www/www/wp-content/plugins/civicrm/civicrm/CRM/Core/Form.php:608 { …}
      /home/gemeingut/www/www/wp-content/plugins/civicrm/civicrm/CRM/Core/QuickForm/Action/Display.php:76 { …}
      /home/gemeingut/www/www/wp-content/plugins/civicrm/civicrm/packages/HTML/QuickForm/Controller.php:203 { …}
      /home/gemeingut/www/www/wp-content/plugins/civicrm/civicrm/packages/HTML/QuickForm/Page.php:103 { …}
      /home/gemeingut/www/www/wp-content/plugins/civicrm/civicrm/CRM/Core/Controller.php:347 { …}
      /home/gemeingut/www/www/wp-content/plugins/civicrm/civicrm/CRM/Utils/Wrapper.php:98 { …}
      /home/gemeingut/www/www/wp-content/plugins/civicrm/civicrm/CRM/Core/Invoke.php:285 { …}
      /home/gemeingut/www/www/wp-content/plugins/civicrm/civicrm/CRM/Core/Invoke.php:68 { …}
      /home/gemeingut/www/www/wp-content/plugins/civicrm/civicrm/CRM/Core/Invoke.php:36 { …}
      /home/gemeingut/www/www/wp-content/plugins/civicrm/civicrm.php:1172 { …}
      /home/gemeingut/www/www/wp-content/plugins/civicrm/includes/civicrm.basepage.php:354 { …}
      /home/gemeingut/www/www/wp-includes/class-wp-hook.php:292 { …}
      /home/gemeingut/www/www/wp-includes/class-wp-hook.php:316 { …}
      /home/gemeingut/www/www/wp-includes/plugin.php:551 { …}
      /home/gemeingut/www/www/wp-includes/class-wp.php:763 { …}
      /home/gemeingut/www/www/wp-includes/functions.php:1291 { …}
      /home/gemeingut/www/www/wp-blog-header.php:16 { …}
      /home/gemeingut/www/www/index.php:17 { …}
    }
  }
]


Apr 05 11:48:09  [debug] $backTrace = #0 /home/gemeingut/www/www/wp-content/plugins/civicrm/civicrm/CRM/Core/Error.php(433): CRM_Core_Error::backtrace("backTrace", TRUE)
#1 /home/gemeingut/www/www/wp-content/plugins/civicrm/civicrm/CRM/Core/Invoke.php(39): CRM_Core_Error::handleUnhandledException(Object(CRM_Core_Exception))
#2 /home/gemeingut/www/www/wp-content/plugins/civicrm/civicrm.php(1172): CRM_Core_Invoke::invoke((Array:3))
#3 /home/gemeingut/www/www/wp-content/plugins/civicrm/includes/civicrm.basepage.php(354): CiviCRM_For_WordPress->invoke()
#4 /home/gemeingut/www/www/wp-includes/class-wp-hook.php(292): CiviCRM_For_WordPress_Basepage->basepage_handler(Object(WP))
#5 /home/gemeingut/www/www/wp-includes/class-wp-hook.php(316): WP_Hook->apply_filters(NULL, (Array:1))
#6 /home/gemeingut/www/www/wp-includes/plugin.php(551): WP_Hook->do_action((Array:1))
#7 /home/gemeingut/www/www/wp-includes/class-wp.php(763): do_action_ref_array("wp", (Array:1))
#8 /home/gemeingut/www/www/wp-includes/functions.php(1291): WP->main("")
#9 /home/gemeingut/www/www/wp-blog-header.php(16): wp()
#10 /home/gemeingut/www/www/index.php(17): require("/home/gemeingut/www/www/wp-blog-header.php")
#11 {main}


Apr 05 12:47:23  [warning] Deprecated Path: There is a setting (generate_schema_and_data) not correctly defined. You may see unpredictability due to this. CRM_Core_Setting::setItems
Array
(
    [civi.tag] => deprecated
)
7
  • Sorry, cannot reproduce... I just sent a test email via Civi 5.35.1 to two recipients added to the "To:" field (not cc: or bcc:). Did not use any tokens. The email was sent and received successfully by both recipients. Running WP 5.4.4.
    – Martin_W
    Apr 5 at 20:54
  • I think the issue is coming from an extension you have installed. are you running the latest of net.ourpowerbase.sumfields/ (ie from github since it looks like releases haven't been dropped for a long time)
    – eileen
    Apr 6 at 4:12
  • Thanks a lot for your reply. I manually updated all extensions just now (including net.ourpowerbase.sumfields/), unfortunately the malfunction persists. It also persists when I deactivate every single extension.
    – Mich___
    Apr 7 at 10:08
  • We are having a similar issue on Drupal - to replicate the error (in Drupal) there needs to be greater than 2 recipients plus an attachment. 2 recipients with an attachment works, as does multiple recipients with no attachment. This was replicated on 2 different sites using different SMTP providers (1 our server, the other CiviSMTP). The PDF tested is only 13kb so would not have hit any size limitations even multiplied by the number of recipients. We tested by viewing the contacts of a group and using the action "Email - send now (to 50 or less)" May 3 at 23:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.