On two Civi 5.35.1 & Joomla sites, I've got the same issue of bulk emails not being sent, but the CiviMail report stating every email has been sent (0 bounces or replies). The 0 bounces bit of the Mail report is what alerted us to something being wrong. Other Civi emails are working fine. On checking, another Civi 5.35.1 & Joomla site using a different host and DNS provider also worked fine for bulk email.

Eventually by looking at the server's mail delivery logs I realised that the emails had never sent, with an error that looks like

587 I=[]:48996 X=TLS1.2:AES128-GCM-SHA256:128 CV=yes DN="/CN=*.filteredmx.net": SMTP error from remote mail server after MAIL FROM:<[email protected]> SIZE=3092: 550-Verification failed for <[email protected]>\n550-Called:\n550-Sent: RCPT TO:<[email protected]>\n550-Response: 550 No Such User Here"\n550 Invalid sender <[email protected]> DT=2.353s

With help from here - Mosaico mailings not sending - I saw this means bounce processsing had stopped working.

I tried with a different email account from an external domain (ie another email address I have) - and it all worked again. So it seems there's two issues here:

  • a Civi error notice issue, because Civi appears to be telling the user mails have been sent when they haven't. It took quite a bit of digging (e.g. turning on MailLog in civicrm.settings.php - gave no insight) before I eventually checked the 'Email Deliverability' screen in Cpanel where I found these errors.

  • and the 'something has changed in the last few weeks' issue - that might have nothing to do with Civi 5.35.x and be more about Cloudflare or Cpanel or our webhosts. What's especially odd is both sites will let me use an external Dreamhost-hosted email for bounce processing, but each of them if I use a correctly setup email account for the same domain the site is hosted at don't work - even tho one is using Gsuite for mail processing and one is using Cpanel.

None of this is urgent any more as we've got CiviMail working again - but still not sure what the wider issue might be (perhaps nothing to do with Civi at all), and thought it useful to track this here because it happened to me on two sites so maybe happens to someone else.

1 Answer 1


Glad you got it working back.

smtp protocol is made to be very resilient, but it means as well it's really hard to know for sure when/what is going wrong.

I'm not sure I understood the details of your configuration, but a somewhat common problem is when you have a local satellite mail server (that will always tell civi the mails are sent as it accepts them) and that isn't able to send it forward for whatever reason... and report that issue in a mailbox that isn't properly read by civi (for another problem).

So from civi point of view, it's all working fine, and in that specific case, it's very difficult to identify there is a problem (or two, as one hides the other), unless you add human brains that is able to identify that it shouldn't have zero bounces and investigate further.

Beside recommending to validate the bounce process and checks that it works on a regular basis, not quite sure how civi can do better on its own.

  • Thanks Xavier. That's fair enough. It's odd both setup stopped working around the same time - and one is using Gsuite and the other the server's mail server – and we still can't get it working with gmail even with a an alphanumeric password. But it works with one of my own email accounts not related to the organisations so it's kind of fixed for now.
    – Nic
    Apr 12, 2021 at 13:05
  • 1
    I think gsuite is really not liking pop/imap, I recall having to change some setting as an admin (something insecure accepted or 2fa and generating a token/pwd just for imap, or sacrificing a goat, the usual google hates you thing). You can google it, and 99% change you'll find a documentation that relates to a previous version that isn't working anymore. #deargoogle
    – Xavier
    Apr 12, 2021 at 17:16
  • 1
    @Nic we had a similar issue with bounces and G Suite, this is what worked: civicrm.stackexchange.com/questions/35648/…
    – LMK Web
    Apr 13, 2021 at 18:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.