0

I am trying to upgrade to the newest security release of Drupal 8 (8.9.14). After completing the update (Drupal is bootstrapping because the login page works) but CiviCRM stops being able to require specific files. The full error is:

PHP Fatal error:  require_once(): Failed opening required 'DB/DataObject.php' (include_path='.:/var/www/site_name/vendor/civicrm/civicrm-core:/var/www/site_name/vendor/civicrm/civicrm-core/packages:.:/var/www/site_name/vendor/civicrm/civicrm-core/:/var/www/site_name/vendor/civicrm/civicrm-core//packages:/var/www/site_name/vendor/civicrm/civicrm-core/vendor/tecnickcom:/var/www/site_name/vendor/pear/archive_tar:/var/www/site_name/vendor/pear/auth_sasl:/var/www/site_name/vendor/pear/console_getopt:/var/www/site_name/vendor/pear/db:/var/www/site_name/vendor/pear/log:/var/www/site_name/vendor/pear/mail:/var/www/site_name/vendor/pear/mail_mime:/var/www/site_name/vendor/pear/net_smtp:/var/www/site_name/vendor/pear/net_socket:/var/www/site_name/vendor/pear/pear-core-minimal/src:/var/www/site_name/vendor/pear/pear_exception:/var/www/site_name/vendor/pear/validate_finance_creditcard:.:/usr/share/pear:/usr/share/php') in /var/www/site_name/vendor/civicrm/civicrm-core/CRM/Core/DAO.php on line 26, referer: https://site.org/user/login

I tried adding the full relative path to the file (../../../civicrm-packages/DB/DataObject.php) and this does not stop the problem.

My CiviCRM root is,

$civicrm_paths['civicrm.root']['path'] = '/var/www/site_folder/vendor/civicrm/'; 

The variable is

$civicrm_root = '/var/www/site_folder/vendor/civicrm/civicrm-core/';

I tried changing the path for the array in ['civicrm.root']['path'] but this did not do anything.

I tried upgrading CiviCRM too. That did not work either.

I have figured out that the issue is not related to the Drupal upgrade itself but rather to the packages being upgraded with Drupal.

  • symfony/debug (v4.4.20 => v4.4.22):
  • symfony/var-dumper (v4.4.21 => v4.4.22):
  • guzzlehttp/psr7 (1.8.1 => 1.8.2)
  • doctrine/cache (1.10.2 => 1.11.0)
  • doctrine/inflector (1.4.3 => 1.4.4)
  • laminas/laminas-feed (2.14.0 => 2.14.1)

I have not narrowed down which library is the issue.

I appreciate any help figuring this out.

Thanks, Josh

1
0

The $civicrm_paths['civicrm.root']['path'] should match with $civicrm_root,

can you try by updating your $civicrm_paths['civicrm.root']['path'] to

$civicrm_paths['civicrm.root']['path'] = '/var/www/networkpaao/vendor/civicrm/civicrm-core/';

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.