0

I have an issue on creating profiles.

When I create a profile with several fields such as "First Name" "Past Name" "E-Mail" and some Custom Fields and I set these fields to "searchable", everything looks fine at first. I can check the preview and the Use - Create/Edit/Listing Modes and it works.

But after a while, it suddenly doesn't work any more:

  • I get for the Listing Mode the error message: "No fields in this Profile have been configured as searchable. Ask the site administrator to check the Profile setup. "
  • Preview is empty
  • Preview od searchable fields tell: "Profile Field Preview This CiviCRM profile field is view only." -> BUT IT IS DEFINITELY SEARCHABLE AND NOT "VIEW ONLY"

for me this feels a bit like a bug. Would be nice to hear if this problem is known and if there is any fix

5
  • Do you have 'Standalone Form or Directory' enabled for the profile? Does it work after CiviCRM cache clear? May 5 at 13:09
  • Yes, standalone is activated. As I said: At first, it was working fine. Only after a while without changing anything, it suddenly produced errors. Therefore, I will check your cache-suggestion, it sounds plausible. May 6 at 8:42
  • Ok this is weird. It works now. It did nothing since yesterday. If the problem returns, I will try clearing the cache. I seems reasonable, that this is some kind of cache problem. May 6 at 8:47
  • Thanks a lot. Clearing the Cach solves the issue to about 90%. I still have problems (I granted edit-permission to a role but it only gets the view-option, despite I enabled edit in the profile, in the ACL and in the Role-permissions). Probably these things will solve out over night again. Anyways, thanks a lot, we are a big step further. May 6 at 9:46
  • After some time, I can say that I still have the same problem and clearing the cache doesn't necessarily solve the issue.
    – Markus
    Jun 7 at 13:20
1

Clearing cache may be the solution? If yes you can turn on 'Clean-up Temporary Data and Files' schedule job with below parameter.

dbCache=1
memCache=1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.