0

I am attempting to activate the CiviCRM 5.37.2 plugin on WordPress 5.7.2 after editing the MySQL connection string. After saving the connection string, I briefly get the CiviCRM "Success" page before I get the infamous WordPress "Whtie screen of death" saying "Sorry, you are not allowed to access this page." (see attached)

To rule out my web hostenter image description here as the source of the issue, I spun up an Amazon Lightsail WP instance and got the exact same behavior. Any help is appreciated.

6
  • Can you detail the server version? php, mysql, and apache/nginx? I did a clean install of WP and CiviCRM with php 7.3, MariaDB 10.3, and Apache 2.4 on a debian server and the install completed as expected. Did you get anything at all in the logs> May 17 at 22:09
  • Hi Kevin, PHP 7.4, MariaDB 10.3, Apache 2.4. I don't have command line access on my webhost, but Lightsail WP was using the official "certified by Bitnami" image. Did you alter the MySQL connection string to something other than the default? (For example, for CiviCRM to use a separate database from the CMS) That's where the issue is occurring for me. Not getting anything in the logs, it craps out and returns to the prior screen. May 18 at 1:31
  • I did set the string to use a different database. the success screen you briefly get is the install success screen May 18 at 7:34
  • Yes I have verified that is the success screen. However, the settings do not save. Is there some bug in CiviCRM? May 19 at 21:00
  • I have been unable to reproduce this on any of the servers we use. If you can give any further details I can see if I can get a failure on my side. One question - if you leave the DB to the same as the WP DB does it succedd or fail? May 20 at 22:21
0

I have the exact same error, I installed on hostgator, 7.3php, Activated and hit either CivicCRM Installer or "CiviCRM is almost ready. You must configure CiviCRM for it to work." After seeing CiviCRM Installed sucessfully it jumps to "wp-admin/admin.php?page=CiviCRM&q=civicrm/admin/access/wp-permissions&reset=1" and i get Sorry, you are not allowed to access this page. Using civicrm-5.39.0-wordpress.zip and the instructions on the wordpress install page.

  • I cleaned out my uploads directory
  • I tried changing permissions
  • I attempted a clean reinstall several times

enter image description here

2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.