1

Here is what happened...

I was doing an update to CiviCRM (through the recommended process) from .10 to .15.

After I copied the files over, I was getting a 500.

So I checked the log and I was getting an error message:

Notice: Constant CIVICRM_MEMCACHE_PREFIX already defined in include_once() (line 310 of /home3/isrcus/public_html/sites/default/civicrm.settings.php).

and the next one:

Deprecated function: Methods with the same name as their class will not be constructors in a future version of PHP; backup_file has a deprecated constructor in require_once() (line 279 of /home3/isrcus/public_html/sites/all/modules/backup_migrate/backup_migrate.module).

Why am I getting those error messages?

Thanks! Kevin

1

Check what settings you have for CIVICRM_MEMCACHE_PREFIX in your civicrm.settings.php file. You can't define a constant more than once. Maybe copy/paste the relevant sections into your question. Don't include the whole file.

The 'Deprecated function' relates to the Drupal backup_migrate module - nothing to to do with CiviCRM. Have you just changed php version? That message relates to a changes introduced in php 7 Make sure your Drupal modules are updated.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.