I've an issue with the plugin CiviMcRestFace. I can't install it in my WP site v. 5.7.2 running on Linux server with php 7.4.6

I download plugin from github (https://github.com/CiviMRF/civimcrestface-wordpress) and then I upload it with WP plugin page. When I try to activate plugin nothing happens, but I can see this error log:

PHP Fatal error: require_once(): Failed opening required '/Volumes/web/default/crm.depadova.com/wp-content/plugins/civimcrestface-wordpress-master//vendor/autoload.php' (include_path='/Volumes/web/default/crm.depadova.com/wp-content/plugins/civicrm/civicrm/ext/form-processor-master/:/Volumes/web/default/crm.depadova.com/wp-content/plugins/civicrm/civicrm/ext/action-provider-master/:/Volumes/web/default/crm.depadova.com/wp-content/plugins/civicrm/civicrm/ext/recaptcha/:/Volumes/web/default/crm.depadova.com/wp-content/plugins/civicrm/civicrm/ext/financialacls/:/Volumes/web/default/crm.depadova.com/wp-content/plugins/civicrm/civicrm/ext/eventcart/:/Volumes/web/default/crm.depadova.com/wp-content/plugins/civicrm/civicrm/ext/greenwich/:.:/Volumes/web/default/crm.depadova.com/wp-content/plugins/civicrm/civicrm:/Volumes/web/default/crm.depadova.com/wp-content/plugins/civicrm/civicrm/packages:/Volumes/web/default/crm.depadova.com/wp-content/plugins/civicrm/civicrm/vendor/tecnickcom:/Volumes/web/default/crm.depadova.com/wp-content/plu in /Volumes/web/default/crm.depadova.com/wp-content/plugins/civimcrestface-wordpress-master/wpcmrf.php on line 32, referer: http://asterix.y-tech.it/crm.depadova.com/wp-admin/plugins.php?plugin=civimcrestface-wordpress-master%2Fwpcmrf.php

Any ideas? many thanks

  • 2
    If you installed from github, have you run the 'composer install' step?
    – Aidan
    May 26 at 12:52

If you install it from github you need to run the following command in the directory of the plugin composer install

This is explained in the readme on Github.

The easiest way to install this plugin is on the Manage plugin page in your wordpress installation and then press add plugin and search for this plugin in the plugin directory.


We've just used and installed this plugin on 5.37.2 as a regular WP extension and it worked fine. No need for a Github version.

  • Can you share me the link where you find the WP extension?
    – Civytech
    May 28 at 12:23
  • I answered too quickly, you have to install from Git with your console: cd wp-content/plugins git clone github.com/CiviMRF/civimcrestface-wordpress.git wpcmrf cd wpcmrf composer install + activate plugin in WP backend May 28 at 13:27
  • 1
    HI,Hello, I solved my issue. To correctly configure the plugin to the remote CiviCRM, we need to use the new version of the WP URLs, that is: "<DOMAIN>/wp-json /civicrm/v3/rest" If ew try to use old version of API call (... / plugins / civicrm / civicrm / ext / rest.php) the plugin does not work.
    – Civytech
    Jun 4 at 8:41

I was able to install the plugin on my WP site. The problem is that the zip downloaded from GitHub does not contain the "vendor" directory ... I don't know why.

I then found the complete plugin at this address: https://it.wordpress.org/plugins/connector-civicrm-mcrestface/ I installed it and set up the remote connection.

In the caldera I created a form and added the processor created in the remote CiviCRM.

However, I encountered first problem: CviCRm responds with "Unable to decode supplied JSON".

Looking at the code I saw that the json parameter is passed as an attribute container ("$ post_data. =" & Json = ". Urlencode (json_encode ($ request));") But the doc civi specifies that "json" should be used to tell the system the type of response: xml or json. In fact, going to modify the portion of code in this way: "& json = 1", CiviCRM is able to manage the call.

But here's a second problem. It seems that the Caldera form parameters are not passed to Civi and the form processor responds with the message: "error_message": "Mandatory key (s) missing from params array ......" FAIL { "entity": "FormProcessor", "action": "nwl_form_ita", "options": [] }

Thanks a lot for the support

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.