2

Drupal security reported Project: Drupal core Date: 2021-May-26 Security risk: Moderately critical 14∕25 AC:Basic/A:User/CI:Some/II:Some/E:Proof/TD:Default Vulnerability: Cross Site Scripting Description: Drupal core uses the third-party CKEditor library. This library has an error in parsing HTML that could lead to an XSS attack. CKEditor 4.16.1 and later include the fix.

What should CiviCRM uses do regarding CKeditor within CiviCRM? Is the library installed or is it served via CDN and updated to the latest version?

2

See https://github.com/civicrm/civicrm-core/pull/20428 which will be in 5.38. But my quick read of it is that the addons affected are not installed by default.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.