0

I have installed the CiviCRM buildkit using Docker. Then i deleted the docker image and installed the buildkit again using Docker but the installation failed. I have stated the error below

+++ '[' '!' -d /buildkit/build/dmaster/web/sites/all/modules/civicrm/bin -o '!' -d /buildkit/build/dmaster/web/sites/all/modules/civicrm/CRM ']'
+++ cvutil_fatal 'Failed to locate valid civi root: /buildkit/build/dmaster/web/sites/all/modules/civicrm'
+++ echo 'Failed to locate valid civi root: /buildkit/build/dmaster/web/sites/all/modules/civicrm'
Failed to locate valid civi root: /buildkit/build/dmaster/web/sites/all/modules/civicrm
+++ exit 90

Thanks in advance.

2

I had the same problem, and I think it's simply likely to mean that civicrm is not installed in your new site. I solved the problem by re-running

civibuild destroy mysitename

civibuild create mysitename --url http://localhost:8080

My initial install command contained an error which explains why civicrm was not downloaded/installed successfully. Short of doing a manual civicrm install via the CMS, there didn't seem an obvious way to fix a missing component from the buildkit install.

If you're using docker, I think you need to prepend 'docker-compose exec -u buildkit civicrm' to those commands, or login to the docker container.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.