When people try donate at this page they are getting a pink bar underneath the credit card entry line that says "Error" no other info on type of error. Credit card and and cvv are valid.


enter image description here

  • I started getting that after updating to latest versions (CiviCRM 5.38, mjwshared (Payment Shared) 1.0, and Stripe Payment Processor 6.6), and flagged it here - lab.civicrm.org/extensions/stripe/-/issues/322. It has been suggested that the 'firewall' extension might be causing this 'parse error' as that had solved it for someone else (disabling didn't solve it for me) Commented Jun 16, 2021 at 6:03
  • emptyhometax.org/civicrm/contribute/transact/?reset=1&id=1 A clue maybe that when I signed in to admin on my wordpress site and go the the live page above the payment is processed. I am using a confirmation page. However, if I try in an incognito tab or have another person try on a different ip it give error as described and won't advance past initial page to confirmation page Commented Jun 16, 2021 at 16:20

2 Answers 2


So I actually solved my issue by going to Wordpress Access Control under Users and Permissions. I just enabled the permissions for Anons under "CiviCRM: access AJAX API Allow API access even if Access CiviCRM is not granted". Payments are going through no problem now.


Just adding a note that this problem can also be caused by the WordPress basepage being set to something other than 'civicrm'. There's no fix for this as yet, with some discussion of potential issues here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.