2

I'm of the "host or you're toast" philosophy so I'm trying to get a working instance of CiviCRM on either a virtual Ubuntu 20.04 instance on a local qemu/kvm server or personal laptop. Usual LAMP with WordPress working. Web install fails on both with the same error about "grouping".

It's a nice refresher course in SQL, etc.

But what should I try to do next to get a working instance? Drop in mariaDB, dump MySQL?

Rip out apt installed CiviCRM. Download the CiviCRM tar.gz to get the latest version?

Forget the web install. Use CLI cv method?

2

It sounds like you have mysql 8. Civi isn't yet fully compatible with mysql 8. So yes for now try mariadb (<= 10.3).

3
  • 1
    Thank you. That worked. At least on my laptop : ) Kicking out MySQL and slipping in Mariadb wasn't as easy for me as the their website would indicate. Took a bit to get Mariadb to start. Now I have to figure out how to do the security updates. Jun 20 at 18:56
  • 2
    According to the docs the latest CiviCRM does support MySQL 8 now (but it looks like this is fairly recent so this may not be the case with older versions): docs.civicrm.org/installation/en/latest/general/requirements/… Jul 2 at 16:37
  • 1
    The key phrase there is "through the execution of our test matrix". But test coverage of civi is low percentage-wise so there will still be places where it doesn't work yet. However, yes it does mean that there is intent to support it fully and if bugfixes are submitted they'll get looked at.
    – Demerit
    Jul 2 at 16:47
1

If you haven't done so already, I suggest you take a look at the Installation Guide and in particular the Requirements.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.