0

I have a profile containing membership fields, and when I created the profile I added a number of membership types. In the profiles administration page, the profile type says: Membership::DPN UK - Dru: DPN UK - Full: DPN UK - Student: DPN Aus - Full: DPN Aus - Student

Now, I have expanded the number of membership types this profile could be used for, so I want to add more membership types to this list. The profile is currently unavailable to people with these new membership types.

How do I do this? Apologies if I'm missing something completely obvious.

I'm in Civi 5.35.2 and Drupal 7.80

2
  • "when I created the profile I added a number of membership types" doesn't quite make sense. You add the membership types to the Custom Fields, not to the Profiles.
    – petednz - fuzion
    Jun 26 at 3:27
  • I am sorry Andyg8, I do not fully understand your question. Are you trying to have custom fields for the membership? Those can be controlled per-membership type. Jun 28 at 5:14
1

Sorry for the confusion here folks, I was mixing 'profiles' with 'custom field sets'.

My membership profile contained custom membership fields and this profile wasn't available when editing or creating some specific membership types.

However, what I didn't realise was that when setting up custom membership fields you must choose which memberships you want these fields to apply to.

I should have gone to Civimenu > Administer > Customise Data and Screens > Custom fields > [my custom field set] > Used for: memberships[choose the correct membership types].

Once I'd chosen the correct membership types, my custom fields became available to these memberships when I edit or create them.

Whew. That's hard to describe in words, yet obvious in just a couple of screens. Hope it all makes sense and helps the next person who makes this mix up.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.