0

I upgraded to Drupal 9.2 in my development environment from Drupal 9.0. We had no problems with this upgrade. However, we have moved the upgrade into our production environment and now we are of course had problems ;).

The CiviCRM menu no longer loads and we get "Unable to reach the server. Please refresh this page in your browser and try again."

Looking at DevTools I see that CiviCRM is doing a GET for "civicrm-placeholder-url-path?code=Eq4nyhc3&locale=en_US&cid=67722" and POST to "/civicrm-placeholder-url-path". Both of these yield 404s.

I have tried cache resets, menu resets, opcache resets, a server restart, but I get the same thing.

I tried upgrading CiviCRM to a newer version but there are composer conflicts that I need to try and work through.

Any help is greatly appreciated.

Thanks!

2

I resolved this by upgrading to CiviCRM 5.39.0. There were a couple of conflicts with libraries with Drupal modules but nothing we could not live without.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.