0

I am running civiCRM 5.39.0 on WordPress 5.8 I am attempting to set up the Cron jobs, using the Cli method. I am running the command from the root folder of the Wordpress install /www/parlemonde_330/public

wp --user=root --url=https://www.parlemonde.org --path=/www/parlemonde_330/public civicrm api job.execute auth=0

It does output:

(
    [is_error] => 0
    [version] => 3
    [count] => 1
    [values] => 1
)

And when I check in civiCRM admin panel, all the scheduled jobs are being triggered :-)

BUT. Then, they do not run on the perodic schedule there are supposed to :-( What am I missing? For exemple, Send Scheduled Mailings is set to "Always"... yet, when I'm sending a mass mailing, it stays as "planned". Maybe related to this issue, when I browse the job logs, the "date" column is always empty. enter image description here

For the record, running wp option get home triggers https://www.parlemonde.org

0
0

Maybe a silly question but are you just manually running that from the command line or did you set this up as an actual cron task? Meaning, depending on your hosting setup the control panel might have a section for cron tasks where you would enter the wp command and can configure the timing. Or if there's no control panel, then this is a good article: https://www.cyberciti.biz/faq/how-do-i-add-jobs-to-cron-under-linux-or-unix-oses/

Also is "root" an actual wordpress user? The --user option is referring to a wordpress admin user. But that's separate from the timing issue.

1
  • Thanks for the reply! I forgot to mention I also used crontab -e to add */5 * * * * wp --user=root --url=https://www.parlemonde.org --path=/www/parlemonde_330/public civicrm api job.execute auth=0 Indeed root is the admin WP user. Jul 23 at 17:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.