Sorry if my English contains mistakes.

I just installed Drupal 8 on Xampp (Windows 10 latest version) with Composer and Drush.

I then used the following commands for civiCRM:

cd /c/xampp/htdocs/site/web/ composer config extra.enable-patching true composer config minimum-stability dev composer require civicrm/civicrm-asset-plugin:'~1.1' composer require civicrm/civicrm-{core,packages,drupal-8}:'~5.39'

I also discovered on the internet that there were various other manipulations to be done:

  • change the access rights for ‘civicrm.settings.php’;
  • activate the "trusted host" to avoid an error in the administration of Drupal;
  • activate the line 'extension = intl' in php.ini; etc.

"cv" being broken from what I could read, I then enabled civiCrm in the extensions and checked user permissions. Everything seems normal, I even tried giving the rights to any authenticated user.

But I am not getting to the civiCRM administration page as you can see. enter image description here

I don't have another error message except "You don't have access to any admin page. " I tried logging out then logging in, but no change. enter image description here

I couldn't find anything on the internet that could help me. Am I missing something? A solution, a piece of advice please?

  • I don't know about the access denied, but it seems like javascript is not loading. Check the browser dev console for errors, and you might also need to re-run composer civicrm:publish which copies the javascript files etc.
    – Demerit
    Commented Jul 24, 2021 at 16:23
  • I relaunched the indicated command but unfortunately that does not solve anything. Commented Jul 24, 2021 at 17:30
  • CiviCRM doesn't have a page under the Configuration menu - I'm not sure what I'm seeing in that screenshot that suggests otherwise. As for Javascript not loading, check the Network tab of the Developer Tools for 404 and 500 errors? Commented Aug 2, 2021 at 14:28
  • 1
    The problem was solved with a fresh install. Thanks for your answers. Commented Aug 3, 2021 at 15:07
  • I am having the same issue in drupal 9 site and can't seem to get this to resolve Commented Jul 19, 2023 at 5:30

1 Answer 1


Check the console if any error is showing and make sure your civicrm.settings.php file has correctly set Base URL path (CIVICRM_UF_BASEURL) and $civicrm_paths['civicrm.files']['url'].

In my case it was base path updated wrongly, I have updated and it started working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.