2

Atempting to add an active Contribution Page to a public Wordpress page but it is not available in the select field in Insert CiviCRM Content in Wordpress. Is this because I am using a separate database for CiviCRM? Using CiviCRM Worpdress Member Sync and it works properly.

Also, when I use the link for the Contribution page: https://domain.com/civicrm/contribute/transact/?reset=1&id=3 or the shortcode [civicrm component="contribution" id="3"]the page displays with the error: "You do not have permission to access this page." The Wordpress page has no content restriction on it.

And, finally a required Username field displays in the Contribution Page form, but no Password or Confirm Password fields. No option to add those on the Contribution Page settings. How do I add the required Password field so it is entered in the Wordpress User account?

1
  • What version of Civi are you using? Jul 26 at 21:14
4

Can you check permissions if the user has permission to make online donations?

If Civi is on 5.37 than password field is not available to set on form, the user will get a password reset link when the user is created.

1
  • Thanks Pradeep, The permissions were correct, but I realized I had set the Profile fields added to the Contribution Page to User and User Admin instead of Expose Publicly. That problem solved and the password issue. First issue re Insert CiviCRM Content still unsolved.
    – Scarlett
    Jul 26 at 21:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.