I've got CiviCRM installed on WordPress and am getting this error for almost every contact that I import from a list of 250 contacts:

"Error when importing contacts: Invalid value for field(s) : State/Province"

The error is showing up for states which use longform state names "Florida" as well as the abbreviated form "FL".

Any idea where I should look to solve this?

  • you say "almost every contact" which seems odd. have you checked that you do not have white space in the data you are importing? Could you convert your values to 1008 (the ID for florida) before you import
    – petednz - fuzion
    Commented Jul 27, 2021 at 19:44
  • I have some cells of my CSV file which are empty. They show up as "" in the file, so I'm not sure if that's what you mean by whitespace. I tried the import using "1008" instead of "FL" and got the same "Invalid value for field(s) : State/Province" error. Commented Jul 29, 2021 at 22:26
  • in your db can you access civicrm_state_province field and confirm the expected values for eg Florida are present
    – petednz - fuzion
    Commented Jul 30, 2021 at 2:52
  • by space i meant eg "Florida " ie whitespace before/after the text that would need trimming to get rid of it
    – petednz - fuzion
    Commented Jul 30, 2021 at 2:52
  • also do a search in civi of someone in Florida, then export using Primary Fields and confirm what is being exported for the State value
    – petednz - fuzion
    Commented Jul 30, 2021 at 2:54

1 Answer 1


I'm not certain exactly what solved the problem, but its working - I believe the change that made it work came from:

Administer -> Localization -> Languages, Currency, Locations

and including states under "Available States and Provinces"

  • ah right. so you had not enabled the States that you were trying to import. a bit surprised to here that impacts on imports but good to know. guess if it did let you import them, but were disabled, then you would not see the data anyway
    – petednz - fuzion
    Commented Aug 10, 2021 at 21:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.