1

After upgrading Wordpress to 5.8 and CiviCRM to 5.39.0, the event registration page does not work.

This is the url:

  • MY-SITE/civicrm/?civiwp=CiviCRM&q=civicrm%2Fevent%2Fregister&reset=1&id=120

These are the symptoms:

  • the h1 of the page is "CiviCRM"
  • the body of the page is "Do not delete this page. Page content is generated by CiviCRM."
  • the title tag in the header contains the title of the event
  • no profile fields, hence no possibility to register for the event.
  • no errors in ConfigAndLog
  • no javascript errors in browser web developer tools
  • several cache clear had no effect

What could be the cause of this error? What can I do to debug this further?

Thanks!

2
1

You will need to comment out line 526 from /includes/civicrm.basepage.php

remove_filter('the_content', [$this, 'basepage_render']);

That should solve it.

7
  • 1
    Thanks a lot, Tommy! Commenting out that line and clearing WP and civi caches solved the problem.
    – AlainB
    Aug 3 at 20:31
  • @AlainB are you using Divi or Avada Theme?
    – Tommy B
    Aug 4 at 15:59
  • @TommyB Are you finding this problematic on all sites or just those using themes like Avada and Divi? Aug 4 at 19:02
  • 1
    @KevinCristiano only Divi so far -- I only suspect avada --- This plugin looks like the long term solution github.com/phdccltd/civicrm-539-wp-content-fix
    – Tommy B
    Aug 4 at 19:33
  • @TommyB It seems that the guy who made the site used the Ken theme.
    – AlainB
    Aug 4 at 21:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.