2

I recently upgraded to 5.39.0 on WP 5.8. When clicking continue from an event registration form at the Confirm Your Registration Information stage, I consistently get the sent to the url suffix https://example.com/civicrm/event/register/ and have the yellow bar page with the message:

Sorry, due to an error, we are unable to fulfill your request at the moment. You may want to contact your administrator or service provider with more details about what action you were performing when this occurred. Failed to find key by ID or tag (:ImagineAKeyHere:)

The participant is successfully registered when looking in the events. Also at other odd times that I have not discerned a pattern a black error box chimes in with

Failed to find key by ID or tag (:ImagineSameKeyHere:)

The baseURLs for CiviCRM and Wordpress are identical per the respective GUIs.

4
  • It seems to be related to a service that is using the new "Crypto Registry". Are you using an external mail server or service?
    – bgm
    Aug 5 at 15:21
  • Yes, I am using an external mail server.
    – Tim
    Aug 5 at 21:11
  • Spot on in the analysis. Still not fixed but hot on the trail. Thanks bgm. An other intel would be much appreciated.
    – Tim
    Aug 5 at 22:26
  • Same error navigating to Administer|System Settings| Outbound email in Debug mode: Civi\Crypto\Exception\CryptoException: Failed to find key by ID or tag (SomeKeyValue) in /var/www/wordpress/wp-content/plugins/civicrm/civicrm/Civi/Crypto/CryptoToken.php on line 143 Exception trace # Function Location 0 Civi\Crypto\CryptoRegistry->findKey(Array) /var/www/wordpress/wp-content/plugins/civicrm/civicrm/Civi/Crypto/CryptoToken.php:143 1 Civi\Crypto\CryptoToken->decrypt(SameKeyValue) /var/www/wordpress/wp-content/plugins/civicrm/civicrm/CRM/Admin/Form/Setting/Smtp.php:259 16 more lines
    – Tim
    Aug 5 at 23:36
2

Thank you bgm, you got me on the right trail. It was an email issue. It was angry that it could not email the confirmation for the event to the registrant. The registrations were hitting the db as expected.

Specifically the civicrm.settings.php file CIVCRM_CRED_KEYS entry did not match what was in the database in the civcrm_setting table, mailing_backend row, and Value field. To make my life easy, I simply deleted the Value field data from the aforementioned in the database and reentered the email config data from the Administer | System Settings | Outbound Email menu. All is well. Thanks again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.