1

I am installing Civi on localhhost. I want to set up a database separate to Wordpress. I am using these credentials: mysql://root:HIDDEN@localhost/cividata. The database username is root, without a password. I get the same issue as described here; Can't connect to separate database. Would it be possible for someone to tell me what the correct syntax should be? Instead of HIDDEN should I use '' Thanks.

3
  • 1
    Can you try mysql://root:@localhost/cividata I would guess it should work with nothing between : and @
    – samuelsov
    Commented Aug 30, 2021 at 20:37
  • "Can you try mysql://root:@localhost/cividata I would guess it should work with nothing between : and @" If that doesn't work, actually lose the ellipse. mysql://root@localhost/cividata Commented Aug 31, 2021 at 13:16
  • Thanks for the answers. I set a password for the database and used that in the login script. I still haven't figured out how to do it without a password. Commented Sep 4, 2021 at 22:53

2 Answers 2

0

My problem turned out to be special characters in the password. Once I changed the password the connection worked fine. To connect to the database, I just changed the path in this line in civicrm-settings.php file to:

define('CIVICRM_DSN', 'mysql://username:password@localhost:3306/databasename?new_link=true');

1
0

The answer to the question about the syntax needed on install when wanting a separate database is as follows. I struggled with this myself today, which was on a Drupal 7 site.

mysql://example_dbuser:password@localhost/example_dbname

where of course example_dbuser is the user name, password is the password without special characters and example_dbname is the separate civicrm database name.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.