Event registrations hang for all events and then gives error whenever "send email confirmation" is set to "yes". While it's hanging, I can see the registration went through, then it finally shows an error with "Could not find valid value for id". I posted the full error at the end of this post.

I tried Amazon SES and sendgrid, getting the same error either way. Either way, sending test emails from outbound email settings works. It just gets stuck sending the email confirmation when registering events.

I'm currently using Drupal 7.37 and CiviCRM 4.6.3.

Full error:

#0 /opt/bitnami/apps/drupal/htdocs/sites/all/modules/civicrm/CRM/Core/Error.php(359): CRM_Core_Error::backtrace()
#1 /opt/bitnami/apps/drupal/htdocs/sites/all/modules/civicrm/CRM/Utils/Request.php(95): CRM_Core_Error::fatal("Could not find valid value for id")
#2 /opt/bitnami/apps/drupal/htdocs/sites/all/modules/civicrm/CRM/Event/Form/Registration.php(183): CRM_Utils_Request::retrieve("id", "Positive", Object(CRM_Event_Form_Registration_Register), TRUE)
#3 /opt/bitnami/apps/drupal/htdocs/sites/all/modules/civicrm/CRM/Event/Form/Registration/Register.php(88): CRM_Event_Form_Registration->preProcess()
#4 /opt/bitnami/apps/drupal/htdocs/sites/all/modules/civicrm/CRM/Core/Form.php(455): CRM_Event_Form_Registration_Register->preProcess()
#5 /opt/bitnami/apps/drupal/htdocs/sites/all/modules/civicrm/CRM/Core/QuickForm/Action/Display.php(94): CRM_Core_Form->buildForm()
#6 /opt/bitnami/apps/drupal/htdocs/sites/all/modules/civicrm/packages/HTML/QuickForm/Controller.php(203): CRM_Core_QuickForm_Action_Display->perform(Object(CRM_Event_Form_Registration_Register), "display")
#7 /opt/bitnami/apps/drupal/htdocs/sites/all/modules/civicrm/packages/HTML/QuickForm/Page.php(103): HTML_QuickForm_Controller->handle(Object(CRM_Event_Form_Registration_Register), "display")
#8 /opt/bitnami/apps/drupal/htdocs/sites/all/modules/civicrm/CRM/Core/Controller.php(353): HTML_QuickForm_Page->handle("display")
#9 /opt/bitnami/apps/drupal/htdocs/sites/all/modules/civicrm/CRM/Core/Invoke.php(312): CRM_Core_Controller->run((Array:3), NULL)
#10 /opt/bitnami/apps/drupal/htdocs/sites/all/modules/civicrm/CRM/Core/Invoke.php(86): CRM_Core_Invoke::runItem((Array:15))
#11 /opt/bitnami/apps/drupal/htdocs/sites/all/modules/civicrm/CRM/Core/Invoke.php(54): CRM_Core_Invoke::_invoke((Array:3))
#12 /opt/bitnami/apps/drupal/htdocs/sites/all/modules/civicrm/drupal/civicrm.module(489): CRM_Core_Invoke::invoke((Array:3))
#13 [internal function](): civicrm_invoke("event", "register")
#14 /opt/bitnami/apps/drupal/htdocs/includes/menu.inc(519): call_user_func_array("civicrm_invoke", (Array:2))
#15 /opt/bitnami/apps/drupal/htdocs/index.php(21): menu_execute_active_handler()
#16 {main}
  • Could you please post your CiviCRM version number and CMS? Commented Jul 19, 2015 at 16:46
  • also confirm your urls aren't jumping from www to non-www etc
    – petednz - fuzion
    Commented Jul 19, 2015 at 20:24
  • Per Pete's comment - if you are starting on a https url & winding up on http or starting on a url with www & winding up on one without you might see something like this - you should ensure that your site is ALWAYS accessed with www or ALWAYS accessed WITHOUT www & that the BASEURL in your civicrm.settings.php reflects this
    – eileen
    Commented Jul 19, 2015 at 20:57
  • Thank you so much for the responses! @JonG I'm currently using Drupal 7.37 and CiviCRM 4.6.3. I'll try to figure out if the http / www is consistent and will post back. Commented Jul 19, 2015 at 22:26
  • @EileenMcNaughton - it seems to always have the www and never has https. I also checked the base url in civicrm.settings.php - it is also http with the www. Is there maybe some page that it's going to behind the scenes to send the confirmation email with the wrong address? Any other suggestions? Thanks so much for your help! Commented Jul 19, 2015 at 23:08

1 Answer 1


This is a known, documented bug that does not seem to have a solution. Please see ref: https://issues.civicrm.org/jira/browse/CRM-17161

I am happy to help a civicrm wizard debug this :)

Also noted here:

CiviEvent - Error when registering: Could not find valid value for id

Even registration emails not going through - registration produces error

Why is the event registration "Thank You" page generating an error?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.