1

I attached a new custom group to entity type group and added a field of type file. When editing the group settings and fill in a file, it is posted without errors and notification bubble confirms success. But there is no file uploaded.

No error logs even with debugging enabled, file tmp folder is checked and I successfully tried another custom file field attached to entity contact.

Just tried on https://dmaster.demo.civicrm.org/ - same misbehavior.

Looked at the code and it seems that the posted file info is not getting into the params array. Although the posted name is of correct format custom_123_21313 the packages/HTML/QuickForm/Controller.php->exportValues gets "MAX_FILE_SIZE" as key for the custom field. Could it be that https://lab.civicrm.org/dev/core/-/blob/master/CRM/Group/Controller.php 's overridden custom file field preparation causes this error?

Civi and Drupal are current versions.

Core Team, do you have a clue? How may I investigate further? Where is the $_POST stuff prepared prior to postProcess in CRM/Group/Form/Edit.php?

1

1 Answer 1

0

This does not work and has never.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.