I recently started using CiviCRM to email about 500 people on my organisation's contacts. The steps I am using here are: Advnaced Search>Search for Groups and Select>Actions>Send Email using CiviCRM. This takes me to the Mailing Window, where I then fill in the Subject, Unsubscribe Group, HTML body, and the other options. The receipient box shows me all the contacts I have selected for the Mailing, and the 'Next' button lightens up as I fill all of the fields.

The problem is, none of the recipients (my personal email is included to the recipient list) are receiving the email. My subscription to CiviCRM spark is the "CiviCRM Spark Hosting - $ 9.50" and not the "CiviCRM Spark Hosting with CiviMail and Mosaico - $ 14.50". Is the issue with the my subscription pack?

Or does it have something to do with Time Zone for CiviCRM? When I click the 'Submit Mailing' button, CIVIcrm tells me that the scheduled time is set behind the User Time. I am in an IST Time Zone, so the CiviCRM time shows as 7.00 AM, when here it is around 5.00 PM/1700 HRS.

If this is an issue with the time zone, do I need to change it. What's the best way to do this.

1 Answer 1


I don't know the details of spark but in a normal site clicking the Send button doesn't actually send it it just schedules it for sending, and then it's up to you to set up the schedule. For spark I assume that schedule is already set up but is maybe infrequent. Check under Mailings - Scheduled and Sent to see if it was actually sent yet, and then if it was, then at Administer - System Settings - Scheduled Jobs you can click the View Logs button to see if there's any log messages.

  • Thank you for the response @Demerit, no the Scheduled and Sent section is empty and there is no entry in the log. Commented Sep 18, 2021 at 14:31
  • Ok then maybe it is the hosting plan. The best way to confirm that would be to email [email protected]
    – Demerit
    Commented Sep 18, 2021 at 16:06
  • thank you, will check with them. :) Commented Sep 20, 2021 at 4:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.