1

Drupal 7.82 Civi 5.41.0

We just updated Civi to 5.41.0. Since the update when we go to a contact and click the contribution tab, we often get a "Network Error: Unable to reach the server" message.

It seems to be certain contacts work and certain ones do not. I have not figured out a connection between those that fail/work.

We have tried it on multiple computers and browsers and the problem in consistent with which donors work/fail.

I checked our .htaccess file and I uncommented the www rewrite rule. I tried it both ways (not at the same time). I looked at our civicrm.settings.php file and the base url is without the www so I left htaccess to rewrite to without. Still not working.

In Chrome and Firefox I get the following error: VM879:1 GET https://secure.radiusinternational.org/civicrm/contact/view/contribution?reset=1&force=1&cid=4297&snippet=json 500 (Service unavailable (with message))

In Civi logs: [warning] Deprecated join alias 'contact' used in APIv4 get. Should be changed to 'contact_id' Caller: Civi\Api4\Query\Api4SelectQuery::autoJoinFK

In Drupal logs: LOCATION https://secure.radiusinternational.org/civicrm/contact/view/contribution?reset=1&force=1&cid=4297&snippet=json

REFERRER https://secure.radiusinternational.org/civicrm/contact/view?reset=1&cid=4297

MESSAGE TypeError: Argument 1 passed to CRM_Financial_BAO_Order::setPriceSetID() must be of the type int, null given, called in .../civicrm/CRM/Financial/BAO/Order.php on line 902 in CRM_Financial_BAO_Order->setPriceSetID() (line 465 of .../civicrm/CRM/Financial/BAO/Order.php).

2
1

Posted in Webform CiviCRM Drupal Issue queue:

<< >>

Webform CiviCRM indeed has not been specific about price_field_id or price_field_value_id in the past - b/c CiviCRM core has been 'fetching' these automatically. When there is a ton of price_fields though (both visible and hidden), the fetching may not produce the correct result or no result at all.

I have already started drafting a better line item branch for Webform CiviCRM to be more specific. Using it for 1 client at this time. It will need to get finalized in the 8.x-5.x version first and secured with a test before we can backport that to 7.x-5.x

1

The problem is having null in civicrm_line_item:price_field_id & price_field_value_id If a donor has one historical contribution that is missing the price field id & price field value id, then you cannot access their contribution tab.

The fix is to fill in the missing fields, a couple of options:

  1. LineItem Edit extension and do them one by one
  2. Use the API Explorer so you can update them in large groupings
  3. SQL update queries

For # 2&3, MAKE A BACKUP of your database before you start in case you change more than you wanted to.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.