0

When importing Contributions, every record returns an error: No matching Contact found for ( ##### )

Importing Contacts isn't an issue. We're running Civi v5.39.0.

I'm matching by Contact ID and they all match, yet 100% of the rows imported return this error with the Contact ID in place of the #####.

10
  • have you checked there is no white space on the cid data you are importing? not sure why else you would get 'no match' if your data has eg a '51' and you have a contact with ID '51'
    – petednz - fuzion
    Oct 13 at 22:57
  • nope, there's no spaces after the ID numbers and I opened it in notepad to look for any funky ASCII codes for whitespaces Oct 13 at 23:17
  • can you run a sample import on dmaster.demo.civicrm.org and report back?
    – petednz - fuzion
    Oct 14 at 7:30
  • No issues importing to dmaster.demo.civicrm.org. I also tried it on wpmaster.demo.civicrm.org and it went through. I notice the Drupal demo site and WordPress demo are both running CiviCRM 5.44.alpha1 - is it possible there's an issue relateed to us running Civi v5.39.0 ? Oct 14 at 17:26
  • asking you to test on master means 'we know the problem does not exist on latest'. next step (sorry) is to test on 'demo' eg drupal.demo.civicrm.org/civicrm/dashboard?reset=1, but tbh my suspicion at this point is that something is slightly misaligned in your configuration. hopefully i am wrong and an upgrade will get you sorted
    – petednz - fuzion
    Oct 14 at 18:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.