1

civicrm = 5.42.1 wordpress = 5.8.1 php = 7.4.24

With a contact selected, I can start an action to 'send an email', the pop-up appears and I can open the drop down list and select a template.

When I go via Mailings - New Mailing, I go to a new webpage e.g. /wp-admin/admin.php?page=CiviCRM&q=civicrm%2Fa%2F#/mailing/347 where I can open the drop down list but I get 'Loading failed' with a nice pink background highlight, but no indication why loading failed.

I can save a template from the bulk email editor, and it shows up in my list of message templates.

I'm tried disabling CKEditor, but that was't the issue. All the directories are default from installation. I've tried resetting caches and updating paths, to no avail.

It's mainly an annoyance, since I can cut'n'paste the raw html from the message templates into a bulk email, but something isn't right. I've tried to use the smartydebug but nothing obvious is showing up, there are two empty arrays but don't know if they're relevant:

assigned config file variables (outer template scope)
{#files#} Array (0)
{#vars#} Array (0)

Do I just bite the bullet and accept the cut'n'paste method, or is there a setting / php anomaly that I can correct?

2
  • You'll need to debug the ajax call, e.g. using the browser dev console on the network tab. When you then click the dropdown, there should be a place you can see the ajax response and it might have more info. Otherwise if it's returning error 500 look in the web server error log (e.g. apache error log) and you should see a more detailed error message there.
    – Demerit
    Oct 25 at 12:55
  • Thanks - just tried that and getting a 403 error Access Forbidden? Which is weird as I haven't changed my account or login on WP / Civi Oct 26 at 8:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.