0

I installed the latest Drupal 9 (9.2.7) using composer as follows:

composer create-project drupal/recommended-project myDrupal9

That gave me the latest/recommended version (9.2.7)

I then tried to install civiCRM using this instructions (only difference is, version installed = Drupal 9.2.7) that failed with the below errors.

Installing civicrm/civicrm-core (5.42.1): Extracting archive
Install of dflydev/apache-mime-types failed
Install of adrienrn/php-mimetyper failed
Install of brick/math failed
Install of brick/money failed
Install of cache/tag-interop failed
Install of cache/integration-tests failed
Install of phpseclib/phpseclib failed
Install of civicrm/civicrm-cxn-rpc failed
Install of zetacomponents/base failed
Install of zetacomponents/mail failed



Failed to download civicrm/civicrm-drupal-8 from dist: web/modules/contrib/civicrm does not exist and could not be created.
Now trying to download from source
unzip:  cannot find or open /var/www/html/myDrupal9/vendor/composer/tmp-efb8b42182d07450c2d7ec823e73087a.

This most likely is due to a custom installer plugin not handling the returned Promise from the downloader
See https://github.com/composer/installers/commit/5006d0c28730ade233a8f42ec31ac68fb1c5c9bb for an example fix
unzip:  cannot find or open /var/www/html/myDrupal9/vendor/composer/tmp-1a4503f846ecbbb0aade402b4254eafa.

This most likely is due to a custom installer plugin not handling the returned Promise from the downloader
See https://github.com/composer/installers/commit/5006d0c28730ade233a8f42ec31ac68fb1c5c9bb for an example fix
Install of tplaner/when failed
Failed to extract totten/ca-config: (9) '/usr/bin/unzip' -qq '/var/www/html/myDrupal9/vendor/composer/tmp-2ddb0683b1b57a00b717f6da8788dd9d' -d '/var/www/html/myDrupal9/vendor/composer/49ca8d4b'

I also tried using the main install page instructions and no luck with similar errors.

I'm using Drupal 9.2.7 since end of life for 9.1.x series is in few weeks.

Using: composer version 2.

PHP 8.0 and MySQL 8.0.

Anybody got ideas?

10
  • What version of composer? Also check permissions on the folders.
    – Demerit
    Oct 31 '21 at 15:46
  • using: composer version 2, PHP 8.0 and MySQL 8.0. Permissions are ok both on folder and /tmp
    – salah-1
    Oct 31 '21 at 15:53
  • 1
    MySQL version shouldn't matter? (I'm pretty sure anyway - I just installed somewhere with no MySQL/Mariadb to check) . I've just successfully run the following: Nov 1 '21 at 0:34
  • composer create-project drupal/recommended-project myDrupal9 Nov 1 '21 at 0:34
  • 1
    This was on a fresh php8 install (I got errors for not having some PHP extensions - so perhaps check you have the required). Otherwise try again with -v (-vv -vvv) to see if you can get some more illuminating error messages. Nov 1 '21 at 0:36
1

Permissions problem on the folders. As per @luke-stewart in the comments running composer with -vvv helps diagnose such problems.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.