Both our donate and membership contribution pages keep failing and saying 'Page Not Found'. https://www.museumofcambridge.org.uk/civicrm/contribute/transact/?reset=1&id=1

We use Wordpress.

Can't find a reason. Has come on and off again with no clear cause.

Test page also not working.

Have cleared cache and did not improve.

Any advice much welcomed!

  • What setting do you have for WordPress Permalinks? Commented Dec 21, 2021 at 11:38
  • It's working now. Please document what you did here for others if you fixed it intentionally! Making sure the contribution page is active?
    – Alan Dixon
    Commented Dec 22, 2021 at 16:52

2 Answers 2


our IT volunteer seems to have fixed it, and said:

The fix is to go to Administer > System Settings > CMS Database Integration from the menus.

And press Save, checking that the writable field on the page (WordPress Base Page setting) says civicrm

We're still not 100% sure what's happening, but that was our fix!

Thanks to those that helped :)


It would seem to me that the URL link is wrong. Could you go into CiviCRM Admin and Contributions/ManageContributionPages/ and on the title of the page you are referring to, click on 'configure'. At the bottom of the page in 'Title and Settings', the correct URL is shown. Copy that URL and make sure that link is used in your wordpress menu settings. Also make sure that this contribution page is Active. Hope this helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.