0

Using CiviCRM 5.36.1 - trying to create email to send using civimail. at: .../wp-admin/admin.php?page=CiviCRM&q=civicrm%2Fa%2F#/mailing/336

Previously had no trouble adding an image by clicking on the add image icon. Now get error when trying to either upload a new image, or linking to an existing image.

Get "incorrect server response" as shown below.

The web console shows: [CKEDITOR] Error code: filetools-response-error. Object { responseText: "
\nDeprecated: The each() function is deprecated.

I removed old images from /public_html/wp/wp-content/uploads/civicrm/persist/contribute/images and still get same error.

Any suggestions?

enter image description here

2 Answers 2

2

I don't know if it is just a coincidence, but after I upgraded the version of php my site uses from 7.3.33 to 7.4.27 I am again able to add images to a draft email.

1

A nice workaround for this is to install the CKEditor5 Extension (https://lab.civicrm.org/extensions/ckeditor5) and follow its setup instructions. Most of the Drupal 9 installs I use, have this problem and it is solved with this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.