After updating to 5.44 I get in my installation (wordpress) "Could not find valid value for id" when the thank you page is called. In Wordpress a "Basepage" is created, the registration also comes through and is entered in the database. Until the beginning of December this always worked. The following error message appears:

CRM_Core_Exception: Konnte keinen gültigen Wert für id finden. in ../httpdocs/wp-content/plugins/civicrm/civicrm/CRM/Event/StateMachine/Registration.php on line 27
Exception trace
#   Function    Location
0   CRM_Utils_Request::retrieve()   ../httpdocs/wp-content/plugins/civicrm/civicrm/CRM/Event/StateMachine/Registration.php:27
1   CRM_Event_StateMachine_Registration->__construct()  ../httpdocs/wp-content/plugins/civicrm/civicrm/CRM/Event/Controller/Registration.php:27
2   CRM_Event_Controller_Registration->__construct()    ../httpdocs/wp-content/plugins/civicrm/civicrm/CRM/Core/Invoke.php:308
3   CRM_Core_Invoke::runItem()  ../httpdocs/wp-content/plugins/civicrm/civicrm/CRM/Core/Invoke.php:69
4   CRM_Core_Invoke::_invoke()  ../httpdocs/wp-content/plugins/civicrm/civicrm/CRM/Core/Invoke.php:36
5   CRM_Core_Invoke::invoke()   ../httpdocs/wp-content/plugins/civicrm/civicrm.php:1169
6   CiviCRM_For_WordPress->invoke() ../httpdocs/wp-content/plugins/civicrm/includes/civicrm.basepage.php:366
7   CiviCRM_For_WordPress_Basepage->basepage_handler()  ../httpdocs/wp-includes/class-wp-hook.php:303
8   WP_Hook->apply_filters()    ../httpdocs/wp-includes/class-wp-hook.php:327
9   WP_Hook->do_action()    ../httpdocs/wp-includes/plugin.php:518
10  do_action_ref_array()   ../httpdocs/wp-includes/class-wp.php:763
11  WP->main()  ../httpdocs/wp-includes/functions.php:1291
12  wp()    ../httpdocs/wp-blog-header.php:16
13  require('/var/www/vhosts/…')    ../httpdocs/index.php:17
14  {main}

1 Answer 1


I just experienced the same issue after updating to 5.45.1. This particular site has had CiviCRM installed for a long time. It was never switched to utilize clean URLs. Once I implemented clean URLs the we no longer get the error.

More info on clean URLs can be found here: https://docs.civicrm.org/sysadmin/en/latest/integration/wordpress/clean-urls/

  • Thank you! this worked for me!
    – themak
    Commented Jun 16, 2022 at 22:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.