0

After an upgrade from 5.38 to 5.44 on a Drupal 8 site the menu and dashboard failed to load. Other page elements, like the footer and header did load. Status page was also inaccessible, but mysite/civicrm/admin and other administrative pages could be accessed. However, edit windows for contacts would just show the spinning throbber and never load, nor would other ajax components work such as help popups, etc. Turning on Debugging, without taking any other action solves all the problems, but obviously I don't want to leave debugging on. Does anyone have thoughts on what might be causing the problem?

UPDATE After checking the console I see that the page is throwing a pile of 403 errors when it attempts to access angular files in /civicrm/persist/contribute/dyn/ BUT ONLY when debugging is disabled. When I turn on debugging the 403 errors disappear.

1
  • 1
    Debugging would turn off caching, so that could explain that difference, and then the issue is probably permissions on that dyn folder, either filesystem or .htaccess somewhere in that path. Can you check the permissions and owner etc?
    – Demerit
    Jan 5 at 20:16

1 Answer 1

2

Long story short, it was a permission issue. A change to groups on my institutions relatively new server left Apache without execute permission on some files and folders in myTheme/civicrm/files. The change was actually a good thing that had been requested some time ago, but I was unaware it was implemented. Reinforcing group read/write/execute on those files solved it. The only remaining mystery is why it was working before the upgrade since the change by our IT person was implemented a few weeks ago.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.