3

When I try to navigate to "system status" nothing shows up now after upgrading to 5.45.1. I get a blank screen.

When I select "administrator" then select "extensions" I receive the error Class 'CRM_Search_Upgrader' not found and I'm asked to go back to control panel.

When I select Civicrm from the Joomla "components" menu I sometimes off and on get the same error message.

I have no idea how to fix this. Please if you answer, walk me through in baby steps if you know how to fix it. Thanks in advance.

7
  • That file is part of search kit. What version are you upgrading from?
    – Demerit
    Jan 13 at 21:57
  • I started having issues when I upgraded from 5.44.0 to 5.45.0. I ALWAYS upgrade as the new ones are released. Is there anyway to get that single file and upload it to the file manager in cpanel? Where would I find that file?
    – Lester
    Jan 13 at 22:25
  • It's here, under ext/search_kit/CRM/Search, just it's strange you'd only be missing one file.
    – Demerit
    Jan 13 at 22:39
  • also doesn't the blank screen at system status suggest an angular issue? so there may be more to it than just one missing file
    – petednz - fuzion
    Jan 13 at 23:30
  • Thank you both for responding, but I'm not missing the "Upgrader.php" file. I have it in my file manager under the same directory ext/search_kit/CRM/Search I have no idea what to look for next. I have a blank system status screen and I cannot access the "extensions"
    – Lester
    Jan 14 at 17:23
2

I've seen this sporadically and have had to run extension upgrades for Search Kit.

If you go to the system status screen /wp-admin/admin.php?page=CiviCRM&q=civicrm%2Fa%2F#/status You should see if any extension updates are needed.

You can force the extension upgrades by going to /wp-admin/admin.php?page=CiviCRM&q=civicrm%2Fadmin%2Fextensions%2Fupgrade&reset=1 or running cv ext:upgrade-db if you have cv and ssh access.

2
  • Yes, I too know that updating extensions is the way to go, but after the 5.44.0 upgrade I can no longer see my system status and have a blank screen. I'm not sure how to force the upgrade. I will read more about this. Thank you for your response!
    – Lester
    Jan 18 at 21:42
  • Can you check the answer from the other post: civicrm.stackexchange.com/questions/41068/…. You might have afform-admin installed. If you have access to the mysql database you can try update civicrm_extension set is_active = 0 where full_name='org.civicrm.afform_admin'; to disable that extension so at least you can get to screens.
    – Demerit
    Jan 19 at 4:40
0

Today, 15Jan2022, I upgraded from CiviCrm 5.36 to 5.45.0 on my staging server which is on Wordpress(5.8.3). I get a Error Thrown ...Class 'CRM_Search_Upgrader' not found when I access the extensions option thru the administration menu.

Caches have been cleared, CiviCrm menu rebuilt and rebuilt database triggers through the Civicrm Admin Utilities. I did get the message that the upgrade was successful.

Has anyone come across the same issue on Wordpress and be able to assist with a solution?

2
  • Wow very similar to what is happening with mine as well. Are you able to see your system status screen? Are you able to select "extensions" under the administrator menu?
    – Lester
    Jan 18 at 21:44
  • I have the same issue and cannot see the system status screen.....pls see this question as I have logged this for Wordpress civicrm.stackexchange.com/questions/41068/… Wordpress 5.8.3
    – markd
    Jan 19 at 4:27
0

Here is what worked best for me based off comments and suggestions posted. I'm unfamiliar with MySQL, so I went into my file manager through my hosting and deleted the "Afform" folder found at administrator > components > com_civicrm > civicrm > ext

After I deleted the folder and refreshed the civicrm home page my "system status" and "extensions" were no longer blank and throwing errors that Afform files were missing. I then was able to install the "Search Kit" in the extensions as recommended. I then reinstalled the Afform folders from the most recent downloads. I'm not sure if this route helps others, but thought I'd try to explain.

If anyone wants to reply and educate me on how to work the above suggestions, I would be grateful for the tutorial. I'm able to access phpmyadmin. From there I have access to all the database tables, and I have SQL tab at the top. I was just unsure what to do next. Thanks to all who helped answer my question!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.