I'm trying to upgrade a site that had not been upgraded since 4.7.31. I tried to go directly to 5.44 but the database upgrade wouldn't run - it just gave me "CiviCRM Upgrade Tasks Retry Skip []" with nothing in the task list.

To resolve this I started upgrading more gradually and was able to get successfully to 5.22.1. But I can't get beyond that. The next version is 5.23.0. Trying to upgrade 5.22.1->5.23.0 gives me the same as the original issue - empty task list at civicrm/upgrade.php "CiviCRM Upgrade Tasks Retry Skip []"

There are no errors in ConfigAndLog and no errors in the error log on the website. Is there somewhere else I should look to see error messages?

The only other thing that I've noticed is that if I run &directoryCleanup=1 I get some error messages such as "Smarty error: the $compile_dir '/home/customer/www/XXXXX/public_html/sites/default/files/civicrm/templates_c/en_US/' does not exist, or is not a directory. in Smarty->trigger_error() (line 1100 of /home/customer/www/XXXXX/public_html/sites/all/modules/civicrm/packages/Smarty/Smarty.class.php)."

The directory definitely does exist. I didn't see anything obviously wrong with the permissions, but this seems like it might be a permissions error since the directory is definitely there.

Any suggestions for next steps would be appreciated.

  • I've got a similar but different upgrade issue. Only some sections have failed but again errors mention smarty and templates and directories. Hmm. civicrm.stackexchange.com/questions/41101/…
    – Eric Booth
    Jan 22, 2022 at 18:02
  • Solved. This was related to civicrm.stackexchange.com/questions/35178/… My [civicrm.root] and [civicrm.files] were not right, and not consistent with [cms.root]. (The clue to this was ERR_NAME_NOT_RESOLVED errors in console on the stuck upgrade page.) I fixed $civicrm_root and CIVICRM_TEMPLATE_COMPILEDIR in civicrm.settings.php and then ran 5.22.1 -> 5.23.0 smoothly. Hurray! I think this happened when a new host migrated our site for us. It's curious that it didn't impact us before. I will try to get the rest of the way later. Jan 24, 2022 at 22:03


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Browse other questions tagged or ask your own question.