0

Wordpress 5.8.3, shared server from SiteGround.

We decided to upgrade from CiviCRM 5.35.2 to 5.45.1 in the hope of resolving an issue preventing supporter registration on website. I'm now stuck on some issues from the upgrade which may not be related to underlying issue but must be resolved first. Seems to be about templates and tokens but I've tried most suggestions I've found on StackExchange. There are also log entries dating back some time about [warning] The system has data from both old+new conventions. Please use civicrm.settings.php to set civicrm.files explicitly.

There were a bunch of warnings on completing the update script about changes to system templates. Taken copies of the modified text and html versions of the following before reverting to default and clearing out the templates_c folder Contributions - Receipt (on-line); Contributions - Receipt (off-line); Memberships - Signup and Renewal Receipts (off-line); Memberships - Receipt (on-line).

Civi admin opens OK and shortcode forms on web pages appear ok but the following actions bring errors:

  1. Opening the System Status page gives yellow error: Sorry, due to an error, we are unable to fulfill your request at the moment. You may want to contact your administrator or service provider with more details about what action you were performing when this occurred. call_user_func() expects parameter 1 to be a valid callback, class 'Closure' does not have a method 'onRegisterTokens'
  2. New Email from Contacts menu causes an out of memory error from Wordpress
  3. Message Templates are listed OK, and System Workflow Messages all show just the edit option meaning all using default, but click edit on any of the System or User-driven templates brings out of memory error.

Tried turning on debug and using Directory Cleanup option &directoryCleanup=3 which seems to successfully flush out the templates_c folder.

I've tried changing civicrm.settings.php override // Override the custom templates directory. $civicrm_setting['Directory Preferences']['customTemplateDir'] = '/home/customer/www/xxx.org.uk/public_html/wp-content/uploads/civicrm/templates_c/';

What else might I try? Thanks!

1 Answer 1

1

As with any long established installation that has been through lots of updates, drilling down through the various symptoms lead down many alleys and dead ends. In the end it came down to a conflict with the Wordpress theme and the Gantry plugin it depended on. Rather than spending further time with providers support and patching, it was easier (!) to switch themes, and then reset and recreate the CiviCRM customised templates.

This doc was helpful in testing using fresh installs and staging copies https://docs.civicrm.org/sysadmin/en/latest/misc/switch-servers/ In particular:

  • checking the paths in civicrm.settings.php,
  • deleting content of /wp-content/plugins/files/civicrm/templates_c/*,
  • checking paths (or deleting) /wp-content/plugins/files/civicrm/ConfigAndLog/Config.IDS.ini

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.