0

My site currently at 5.39.1, error did not occur at 5.35.2 .

I'm getting an error loading the latest contribution / donor dashlets. The case and news dashlet loads without issues.

Results are showing up fine at contributions dashboard wp-admin/admin.php?page=CiviCRM&q=civicrm%2Fcontribute&reset=1

I don't know why the getRowCount is null from the stacktrace below.

Please advise?

CiviCRM error popup:

Network Error
Unable to reach the server. Please refresh this page in your browser and try again.

Traffic response:

500 Internal Server Error
/wp-admin/admin.php?page=CiviCRM&q=civicrm/report/instance/13&reset=1&section=2&context=dashlet&rowCount=10&snippet=json

Your Site is Experiencing a Technical Issue - automated email from Wordpress (i replaced the folder names as they are not relevant)

Error Details

An error of type E_ERROR was caused in line 535 of the file /<folder names>/public_html/wp-content/plugins/civicrm/civicrm/CRM/Report/Form.php. 

Error message: Uncaught TypeError: Return value of CRM_Report_Form::getRowCount() must be of the type int, null returned in /<folder names>/public_html/wp-content/plugins/civicrm/civicrm/CRM/Report/Form.php:535

Stack trace:

#0 /<folder names>/public_html/wp-content/plugins/civicrm/civicrm/CRM/Report/Form.php(3611): CRM_Report_Form->getRowCount()

#1 /<folder names>/public_html/wp-content/plugins/civicrm/civicrm/CRM/Report/Form/Contribute/Detail.php(522): CRM_Report_Form->limit()

#2 /<folder names>/public_html/wp-content/plugins/civicrm/civicrm/CRM/Report/Form.php(3586): CRM_Report_Form_Contribute_Detail->buildQuery()

#3 /<folder names>/public_html/wp-content/plugins/civicrm/civicrm/CRM/Report/Form.php(930): CRM_Report_Form->postProcess()

#4 /<folder names>/public_html/wp-content/plugins/civicrm/civicrm/CRM/Core/Form.php(621): CRM_Report_Form->preProcess()

#5 /<folder names>/public_html/wp-content/plugins/civicrm/civicrm/CRM/Core/QuickForm/Action/Display.php(76): CRM_Core_Form->buildForm()

#6 /<folder names>/public_html/wp-co
1
  • Critical error also happens for other report instances /wp-admin/admin.php?page=CiviCRM&q=civicrm/report/instance/20
    – humanistsg
    Jan 23 at 5:16

1 Answer 1

1

With help from a friend, we guess it has something to do with default_pager_size.

$this->setRowCount(\Civi::settings()->get('default_pager_size'));

So i went to set the "Default Search Pager size" in "Settings - Search Preferences" to another value in an attempt to refresh the value and it worked. Dashlets are populating fine now.

1
  • Something like this has come up before but it wasn't reproducible. What normally happens with \Civi::settings()->get is it will pull the default from "metadata", in this case this line: github.com/civicrm/civicrm-core/blob/…. But for some reason you were getting null instead of the default. Setting it on the settings page will then use that value, so that "fixes" it, but it's supposed to pick up the default from the file if you haven't set it on the settings page. Sometimes it just needs a cache clear.
    – Demerit
    Mar 12 at 19:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.