0

After making configuration changes to the Parameter Group for both the database and cluster of my Amazon Aurora database I can no longer access CiviCRM. I get the following error: Error code 19, "DB Error: no such field". It has this for debug info:

SELECT path, data, UNIX_TIMESTAMP(expired_date) AS expires FROM civicrm_cache WHERE group_name = "2c60b3a2e8a19ac496e9716cc54d45a8" [nativecode=1054 ** Unknown column '2c60b3a2e8a19ac496e9716cc54d45a8' in 'where clause']

Before I made the changes to my server the entire Drupal site was only loading the install page with issues with the cache. I believe this was because the max_allowed_packets was not large enough. I have now set the max_allowed_packets to the highest size using Parameter Groups.

Drupal cannot bootstrap and cv flush will not work either because it appears to be attempting to bootstrap Drupal. I have truncated the civicrm_cache table. Before I did that there was a group_name value of 2c60b3a2e8a19ac496e9716cc54d45a8 in the table.

I have Drupal 9.3.3. We have been running 9.3.3 for about a week before we have had problems. We have CiviCRM 5.45.2. We have been running this for about a week as well.

I am not sure what to do to get CiviCRM to correct this query so that I can bootstrap everything.

Thanks,

Josh

1 Answer 1

1

When you made your config changes did you turn on ANSI or ANSI_QUOTES in your sql_mode?

It prevents using " as a string quoting character which is not a standard string quoting character in sql, and so will break civi since civi does nonstandard things.

3
  • Thank you but that is not how the database is configured now. I did turn on ANSI but then I turned it off. Could I have damaged the database? I think I will restore from a clone just to see if that works.
    – Josh
    Feb 4 at 14:19
  • I don't think it would have damaged it, but it's possible mysql needs a restart to pick up the change. If you do SELECT @@sql_mode; you can confirm if ANSI is removed or not.
    – Demerit
    Feb 4 at 14:28
  • 1
    I should not have needed to but I needed to restart the database. Thanks!
    – Josh
    Feb 7 at 3:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.